Modify

Opened 9 years ago

Closed 8 years ago

#3258 closed defect (fixed)

Remoteplugin: Bug while loading from a page (ConcurrentModificationException, LinkedList)

Reported by: AndreR Owned by: framm
Priority: blocker Milestone:
Component: Core remotecontrol Version: latest
Keywords: Remotecontrol Cc: delta_foxtrot@…

Description (last modified by stoecker)

I got the following bug while loading a region from the "Aktion 01" (No. 309). You can find the list at <http://www.gary68.de/osm/qa/c33/c33_bayern.htm>. The Link for the RM is <http://localhost:8111/load_and_zoom?left=11.342711&right=11.362711&top=49.0558558&bottom=49.0358558&select=way27069921,way24421178>


Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1951
Node Kind: directory
Last Changed Author: jttt
Last Changed Rev: 1951
Last Changed Date: 2009-08-10 20:36:40 +0200 (Mon, 10 Aug 2009)

Memory Usage: 71 MB / 1016 MB (3 MB allocated, but free)
Java version: 1.6.0_14

Plugins: graphviewopenstreetbugsremotecontrolterracerusertoolsutilspluginvalidatorwalkingpaperswaydownloaderwmsplugin
Plugin graphview Version: 16836
Plugin openstreetbugs Version: 16797
Plugin remotecontrol Version: 16965
Plugin terracer Version: 16626
Plugin usertools Version: 14125
Plugin utilsplugin Version: 16735
Plugin validator Version: 16970
Plugin walkingpapers Version: 16879
Plugin waydownloader Version: 16963
Plugin wmsplugin Version: 16872

java.util.ConcurrentModificationException

at java.util.LinkedList$ListItr.checkForComodification(Unknown Source)
at java.util.LinkedList$ListItr.next(Unknown Source)
at org.openstreetmap.josm.data.osm.DataSet.fireSelectionChanged(DataSet.java:244)
at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:193)
at org.openstreetmap.josm.plugins.remotecontrol.RequestProcessor$1.run(RequestProcessor.java:200)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by plaicy

Maybe a real concurrent problem:

OsbLayer is constructed org.openstreetmap.josm.plugins.osb.OsbDownloadLoop.run. Inside org.openstreetmap.josm.plugins.osb.OsbLayer is constructed. The constructor calls DataSet.selListeners.add. If this run at the same time as org.openstreetmap.josm.data.osm.DataSet.fireSelectionChanged this error might arraise.

comment:2 Changed 9 years ago by plaicy

Ticket #3257 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by delta_foxtrot2

Cc: delta_foxtrot@… added

comment:4 Changed 9 years ago by stoecker

Component: PluginCore remotecontrol
Description: modified (diff)
Owner: changed from team to framm

comment:5 Changed 8 years ago by anonymous

Ticket #3691 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by anonymous

Summary: Remoteplugin: Bug while loading from a pageRemoteplugin: Bug while loading from a page (ConcurrentModificationException, LinkedList)

comment:7 Changed 8 years ago by hansendc

Priority: criticalblocker
Resolution: fixed
Status: newclosed

Hopefully fixed in rev 2515.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.