Modify

Opened 13 years ago

Closed 13 years ago

#3248 closed defect (fixed)

Exception occured

Reported by: Nakor Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I was uploading some changes when the following error occured:

Manifest-Version: 1.0
Created-By: 1.6.0_0 (Sun Microsystems Inc.)
Memory Usage: 219 MB / 508 MB (64 MB allocated, but free)
Java version: 1.6.0_0

Plugins: PicLayer
editgpx
graphview
remotecontrol
routing
utilsplugin
validator
waydownloader
wmsplugin
Plugin PicLayer Version: 16302
Plugin editgpx Version: 16294
Plugin graphview Version: 16605
Plugin remotecontrol Version: 16624
Plugin routing Version: 16409
Plugin utilsplugin Version: 16687
Plugin validator Version: 16629
Plugin waydownloader Version: 16631
Plugin wmsplugin Version: 16599

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.gui.PleaseWaitRunnable$2.run(PleaseWaitRunnable.java:98)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Caused by: java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(EventQueue.java:1000)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:67)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:116)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)

Caused by: java.lang.ClassCastException: Cannot cast java.io.IOException to java.net.SocketException

at java.lang.Class.cast(Class.java:3007)
at org.openstreetmap.josm.gui.ExceptionDialogUtil.getNestedException(ExceptionDialogUtil.java:183)
at org.openstreetmap.josm.gui.ExceptionDialogUtil.getNestedSocketException(ExceptionDialogUtil.java:206)
at org.openstreetmap.josm.gui.ExceptionDialogUtil.explainOsmTransferException(ExceptionDialogUtil.java:231)
at org.openstreetmap.josm.gui.ExceptionDialogUtil.explainException(ExceptionDialogUtil.java:290)
at org.openstreetmap.josm.actions.UploadAction.handleFailedUpload(UploadAction.java:396)
at org.openstreetmap.josm.actions.UploadAction$UploadDiffTask.finish(UploadAction.java:557)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:69)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:216)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
at java.awt.Dialog$1.run(Dialog.java:1072)
at java.awt.Dialog$3.run(Dialog.java:1126)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:1124)
at java.awt.Component.show(Component.java:1464)
at java.awt.Component.setVisible(Component.java:1416)
at java.awt.Window.setVisible(Window.java:842)
at java.awt.Dialog.setVisible(Dialog.java:1011)
at org.openstreetmap.josm.gui.PleaseWaitDialog.setVisible(PleaseWaitDialog.java:100)
at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:93)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (0)

Change History (1)

comment:1 Changed 13 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [1957]) fixed #3248: Exception occured

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.