Modify

Opened 11 years ago

Closed 10 years ago

#3233 closed defect (fixed)

Relation list doesn't update when a data layer is deleted

Reported by: Daeron Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

When data layer is deleted, the relation list doesn't update and shows all the relations that were available in that layer. Trying to edit one of the shown relations results in NPE:

java.lang.NullPointerException
        at org.openstreetmap.josm.gui.dialogs.RelationListDialog$EditAction.getMembersForCurrentSelection(RelationListDialog.java:271)
        at org.openstreetmap.josm.gui.dialogs.RelationListDialog$EditAction.launchEditor(RelationListDialog.java:283)
        at org.openstreetmap.josm.gui.dialogs.RelationListDialog$EditAction.actionPerformed(RelationListDialog.java:289)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
        at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
        at java.awt.Component.processMouseEvent(Component.java:6216)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
        at java.awt.Component.processEvent(Component.java:5981)
        at java.awt.Container.processEvent(Container.java:2041)
        at java.awt.Component.dispatchEventImpl(Component.java:4583)
        at java.awt.Container.dispatchEventImpl(Container.java:2099)
        at java.awt.Component.dispatchEvent(Component.java:4413)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4556)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4220)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4150)
        at java.awt.Container.dispatchEventImpl(Container.java:2085)
        at java.awt.Window.dispatchEventImpl(Window.java:2475)
        at java.awt.Component.dispatchEvent(Component.java:4413)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (7)

comment:1 Changed 11 years ago by Gubaer

Resolution: fixed
Status: newclosed

fixed in r1944

comment:2 Changed 10 years ago by vsandre

Resolution: fixed
Status: closedreopened

Same behaviour with r2818, relations are editable but no NPE occurs. It is also possible to edit a node via selecting it in the relation editor.

The MOTD-Screen is not shown because of the used slippymap-plugin. But the problem should be solved in JOSM core.

comment:3 Changed 10 years ago by Gubaer

Owner: changed from team to Daeron
Status: reopenedneedinfo

Can't reproduce.

  • downloaded data including a relation into "layer 1"
  • created a new "layer 2"
  • activate "layer 1"
  • deleted "layer 1"

Findings:

  • everything is fine, "layer 2" is active, no relations are shown in the Relation Dialog

Can you be more specific? What steps lead to the problem?

comment:4 Changed 10 years ago by Daeron

Owner: changed from Daeron to vsandre
Status: needinfonew

I didn't reopen, but I can reproduce the bug:

  1. Download some data that has relations
  2. Add a WMS-layer
  3. Delete the data layer

The relations are still all visible, and editable.

comment:5 in reply to:  4 Changed 10 years ago by vsandre

Owner: changed from vsandre to team

Replying to Daeron:

I didn't reopen, but I can reproduce the bug:

  1. Download some data that has relations
  2. Add a WMS-layer
  3. Delete the data layer

The relations are still all visible, and editable.

That is exatly what I mean ;-). Sorry for the short report.

comment:6 Changed 10 years ago by jttt

Confirmed, working on that...

comment:7 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2860]) Fixed #3233 Relation list doesn't update when a data layer is deleted

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.