Modify

Opened 12 years ago

Closed 12 years ago

#3192 closed defect (fixed)

Import error (not reproducable)

Reported by: Morjo Owned by: team
Priority: trivial Milestone:
Component: unspecified Version: latest
Keywords: Cc:

Description

OS: Mac OS X 10.5.7
(1) Imported many GPX-Tracks
(2) Downloaded a small part with the interactive map. While Downloading the error occured

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1788
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1788
Last Changed Date: 2009-07-14 18:20:56 +0200 (Tue, 14 Jul 2009)

Memory Usage: 80 MB / 506 MB (45 MB allocated, but free)
Java version: 1.6.0_13

Plugins: wmsplugin
Plugin wmsplugin Version: 16442

java.lang.NullPointerException

at javax.swing.plaf.basic.BasicProgressBarUI.sizeChanged(BasicProgressBarUI.java:956)
at javax.swing.plaf.basic.BasicProgressBarUI.setAnimationIndex(BasicProgressBarUI.java:916)
at javax.swing.plaf.basic.BasicProgressBarUI.incrementAnimationIndex(BasicProgressBarUI.java:983)
at javax.swing.plaf.basic.BasicProgressBarUI$Animator.actionPerformed(BasicProgressBarUI.java:1191)
at javax.swing.Timer.fireActionPerformed(Timer.java:271)
at javax.swing.Timer$DoPostEvent.run(Timer.java:201)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:633)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:205)
at java.awt.Dialog$1.run(Dialog.java:1051)
at java.awt.Dialog$3.run(Dialog.java:1103)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:1101)
at java.awt.Component.show(Component.java:1516)
at java.awt.Component.setVisible(Component.java:1468)
at java.awt.Window.setVisible(Window.java:841)
at java.awt.Dialog.setVisible(Dialog.java:991)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.prepareDialog(PleaseWaitRunnable.java:89)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.access$300(PleaseWaitRunnable.java:29)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$5.run(PleaseWaitRunnable.java:141)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:633)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Gubaer

Resolution: fixed
Status: newclosed

This is most likely due to a race condition in r1788. Recently there was a major update in JOSM which should fix these issues.

You may upgrade to JOSM latest which is r1909 or wait for the next tested release.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.