Modify

Opened 9 years ago

Closed 9 years ago

#3174 closed defect (fixed)

Bug by loading data

Reported by: Luebeck Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1892
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 1892
Last Changed Date: 2009-08-03 00:17:45 +0200 (Mon, 03 Aug 2009)

Memory Usage: 36 MB / 1016 MB (14 MB allocated, but free)
Java version: 1.6.0

Plugins: AgPifoJ
Intersect_way
PicLayer
dataimport
editgpx
openstreetbugs
remotecontrol
tageditor
utilsplugin
walkingpapers
wmsplugin
Plugin AgPifoJ Version: 16603
Plugin Intersect_way Version: 12781
Plugin PicLayer Version: 16302
Plugin dataimport Version: 16382
Plugin editgpx Version: 16294
Plugin openstreetbugs Version: 16622
Plugin remotecontrol Version: 16624
Plugin tageditor Version: 16605
Plugin utilsplugin Version: 16628
Plugin walkingpapers Version: 16571
Plugin wmsplugin Version: 16599

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.gui.PleaseWaitRunnable$2.run(PleaseWaitRunnable.java:98)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Caused by: java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:67)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:116)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.NullPointerException

at org.openstreetmap.josm.gui.layer.Layer.setName(Layer.java:172)
at org.openstreetmap.josm.gui.layer.Layer.<init>(Layer.java:97)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.<init>(OsmDataLayer.java:174)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$Task.finish(DownloadOsmTask.java:127)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:69)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitDialog.setVisible(PleaseWaitDialog.java:100)
at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:93)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

German: habe lediglich versucht Daten vom Server zu laden

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by Gubaer

Resolution: fixed
Status: newclosed

There's an annoying bug in r1892 (~ todays latest). Please upgrade to r1893.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.