Modify

Opened 15 years ago

Closed 9 years ago

Last modified 9 years ago

#3145 closed enhancement (fixed)

listing custom presets within default groups

Reported by: Landwirt Owned by: team
Priority: major Milestone: 15.08
Component: Internal preset Version:
Keywords: own presets default groups Cc:

Description

I tried to add a preset for waterway=ditch by using an own presets file. It appears in the Presets menu, but I can't add it to the Water submenu. In the presets file I have put it into a group called Water like in the default presets and now I have two Water submenus instead of one. Is there already a way to add own presets to existing preset groups? If not, could that feature be added?

Attachments (0)

Change History (7)

comment:1 by ce, 15 years ago

Owner: changed from ce to team

I cannot really do anything about this issue concerning the presets. It's mainly a design question: If someone creates her own presets containing already existing group names, should they be kept separately (as it is) or merged?

comment:2 by skyper, 12 years ago

Would be nice if it possible to merge them.

comment:3 by anonymous, 11 years ago

It would be nice if different presets for the same item could be merged (i.e. making regional presets merge with global presets). I have my own preset giving me a drop down menu to add network=* tag to highways, having this merged with the existing highway preset would make it much easier to use, and could also have multiple advantages when combining presets of various special interests.

comment:4 by kocio, 9 years ago

I think if someone creates custom presets containing already existing group names, they should be merged. In case the custom name is the duplicate of the inner preset name in the same subcategory, custom presets might be automatically shown just as "Name (custom)".

comment:5 by simon04, 9 years ago

Resolution: fixed
Status: newclosed

In 8492/josm:

fix #3145 - Allow listing custom presets within default groups

The non-translated group names are taken as criterion.

comment:6 by simon04, 9 years ago

Milestone: 15.07

comment:7 by Don-vip, 9 years ago

Milestone: 15.0715.08

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.