Modify

Opened 13 years ago

Closed 13 years ago

#3138 closed defect (fixed)

500 - Internal Server Error while downloading GPS-raw and OSM data

Reported by: kallies Owned by: team
Priority: minor Milestone:
Component: Core Version: tested
Keywords: http 500 download Cc:

Description

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1788
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1788
Last Changed Date: 2009-07-14 18:20:56 +0200 (Tue, 14 Jul 2009)

Memory Usage: 413 MB / 865 MB (194 MB allocated, but free)
Java version: 1.6.0_14

Plugins: lakewalkermeasurementutilspluginvalidator
Plugin lakewalker Version: 15961
Plugin measurement Version: 16317
Plugin utilsplugin Version: 16290
Plugin validator Version: 16439

java.lang.RuntimeException: java.lang.RuntimeException: org.openstreetmap.josm.io.OsmApiException: ResponseCode=500, Error Body=<<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 TransitionalEN"

"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head>

<title>500 - Internal Server Error</title>

</head>
<body>

<h1>500 - Internal Server Error</h1>

</body>

</html>>

at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:120)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Caused by: java.lang.RuntimeException: org.openstreetmap.josm.io.OsmApiException: ResponseCode=500, Error Body=<<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 TransitionalEN"

"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head>

<title>500 - Internal Server Error</title>

</head>
<body>

<h1>500 - Internal Server Error</h1>

</body>

</html>>

at org.openstreetmap.josm.io.BoundingBoxDownloader.parseRawGps(BoundingBoxDownloader.java:84)
at org.openstreetmap.josm.actions.downloadtasks.DownloadGpsTask$Task.realRun(DownloadGpsTask.java:40)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:144)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

Caused by: org.openstreetmap.josm.io.OsmApiException: ResponseCode=500, Error Body=<<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 TransitionalEN"

"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head>

<title>500 - Internal Server Error</title>

</head>
<body>

<h1>500 - Internal Server Error</h1>

</body>

</html>>

at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:95)
at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:45)
at org.openstreetmap.josm.io.BoundingBoxDownloader.parseRawGps(BoundingBoxDownloader.java:51)
... 9 more

Attachments (0)

Change History (2)

comment:1 Changed 13 years ago by Gubaer

The error itself is caused by an internal server error of the OSM API server. There's not much JOSM can do here. I've improved the feedback to the user though. There's now a special error message for internal server errors.

comment:2 Changed 13 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2002]) fixed #3138: 500 - Internal Server Error while downloading GPS-raw and OSM data

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.