Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3084 closed defect (fixed)

Can't zoom more than "58m" on scale with lambert france coordonates

Reported by: gilles.lamiral@… Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: zoom lambert france Cc:

Description

Hello,

We can't zoom more than "58m" scale with lambert france
projection. The cadastre can't be used easily (very precise source).

Release 1826 and maybe two/three previous ones.

Thanks in advance.

Attachments (1)

Lambert.patch (2.2 KB) - added by pieren 10 years ago.
patch for #3084

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by stoecker

Hmpf, somehow my new code to detect the zoom depths is not as exact as I thought it should be.

Does this happen with all zoom methods (i.e. +,-, scroolwheel and zoom bar)?

Changed 10 years ago by pieren

Attachment: Lambert.patch added

patch for #3084

comment:2 in reply to:  1 Changed 10 years ago by pieren

Replying to stoecker:

Hmpf, somehow my new code to detect the zoom depths is not as exact as I thought it should be.

Does this happen with all zoom methods (i.e. +,-, scroolwheel and zoom bar)?

The problem seems to be in the new method getWorldBoundsLatLon() which seems to limit the zoom if the bound is -90/90 :
{

return new Bounds(
new LatLon(-90.0, -180.0),
new LatLon(90.0, 180.0));

}

I have attached a patch file called Lambert.patch if you could apply it. It's also a small code cleanup.

comment:3 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

In r1849.

Seems I forgot to enter correct values when I changed Lambert.java.

Nevertheless there are still some quirks in the projection code but I hope they will vanish step by step :-)

comment:4 Changed 10 years ago by anonymous

Ticket #3081 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.