Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#3047 closed defect (duplicate)

Relation sorting adds new members - destroying data!

Reported by: xylome Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: relation sorting Cc:


initially has 59 members. after sorting one member is duplicated.
i know sorting osm relations is a pain (circular ways, Ts, ...) so there should be a due diligence test after the sort process. e.g. same number of members, same members as before...

as long as this is not fixed: disable sorting... it destroys data without notice!

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by cjw@…

Resolution: duplicate
Status: newclosed

duplicate of #2953, fixed in r1828 (and sorting was removed/disabled from r1790)

comment:2 Changed 9 years ago by anonymous

Closed as duplicate of #2953.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.