Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3033 closed defect (fixed)

NullPointerException plugins.routes.RouteLayer.paint(RouteLayer.java:99)

Reported by: phobie Owned by: jttt
Priority: major Milestone:
Component: Plugin Version:
Keywords: NullPointerException RouteLayer paint SystemEventQueueUtilities ComponentWorkRequest Cc:

Description

How to reproduce:
Install the routes plugin (I installed all plugins for testing...).
Download a area.
In the Layers window click on and other layer than the main data layer.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1822
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 1822
Last Changed Date: 2009-07-21 20:42:50 +0200 (Tue, 21 Jul 2009)


Memory Usage: 357 MB / 986 MB (92 MB allocated, but free)
Java version: 1.6.0_14

Plugins: *removed*
Plugin plastic_laf Version: 14016
Plugin AgPifoJ Version: 16603
Plugin ColumbusCSV Version: 35
Plugin Create_grid_of_ways Version: 16620
Plugin DirectUpload Version: 16583
Plugin ImageWayPoint Version: 16294
Plugin Intersect_way Version: 12781
Plugin PicLayer Version: 16302
Plugin buildings_tools Version: 19
Plugin colorscheme Version: 16383
Plugin czechaddress Version: 16417
Plugin dataimport Version: 16382
Plugin editgpx Version: 16294
Plugin globalsat Version: 14015
Plugin graphview Version: 16605
Plugin lakewalker Version: 16621
Plugin livegps Version: 16294
Plugin measurement Version: 16317
Plugin multipoly Version: 16609
Plugin nearclick Version: 14015
Plugin openstreetbugs Version: 16622
Plugin openvisible Version: 15707
Plugin osmarender Version: 16623
Plugin remotecontrol Version: 16624
Plugin routes Version: 16593
Plugin routing Version: 16409
Plugin slippymap Version: 16294
Plugin tageditor Version: 16605
Plugin tagging-preset-tester Version: 14015
Plugin terracer Version: 16162
Plugin usertools Version: 14125
Plugin utilsplugin Version: 16628
Plugin validator Version: 16629
Plugin walkingpapers Version: 16571
Plugin waydownloader Version: 16590
Plugin wmsplugin Version: 16599
Plugin cadastre-fr Version: 16620
Plugin surveyor Version: 16625


java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.routes.RouteLayer.paint(RouteLayer.java:99)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:284)
	at javax.swing.JComponent.paintChildren(JComponent.java:864)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5124)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:278)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1220)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5072)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4882)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:803)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:714)
	at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:694)
	at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:128)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by stoecker

Component: Plugin routingPlugin
Owner: changed from vidalfree@… to team

comment:2 Changed 10 years ago by jttt

Owner: changed from team to jttt

comment:3 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

Fixed in r1825

comment:4 Changed 10 years ago by jttt

Ticket #3058 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jttt.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.