Modify

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#3010 closed defect (fixed)

NullPointerException at ...plugins.PluginSelection.update(PluginSelection.java:69)

Reported by: phobie Owned by: jttt
Priority: minor Milestone:
Component: Core Version:
Keywords: Cc:

Description

Downloaded JOSM rev 1815
Deleted my plugins dir,
started JOSM,
opened Preferences --> Plugins,
deselected all plugins except "routing",
clicked on "Download List"
clicked on "Update"

I attached my preferences file

OpenGL pipeline enabled for default config on screen 0                                                                       
Exception occurred during event dispatching:                                                                                 
java.lang.NullPointerException                                                                                               
        at org.openstreetmap.josm.plugins.PluginSelection.update(PluginSelection.java:69)                                    
        at org.openstreetmap.josm.gui.preferences.PluginPreference$2.actionPerformed(PluginPreference.java:60)               
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)                                          
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)                                      
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)                                   
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)                                            
        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)                            
        at java.awt.Component.processMouseEvent(Component.java:6263)                                                         
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)                                                    
        at java.awt.Component.processEvent(Component.java:6028)                                                              
        at java.awt.Container.processEvent(Container.java:2041)                                                              
        at java.awt.Component.dispatchEventImpl(Component.java:4630)                                                         
        at java.awt.Container.dispatchEventImpl(Container.java:2099)                                                         
        at java.awt.Component.dispatchEvent(Component.java:4460)                                                             
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)                                            
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)                                             
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)                                                 
        at java.awt.Container.dispatchEventImpl(Container.java:2085)                                                         
        at java.awt.Window.dispatchEventImpl(Window.java:2475)                                                               
        at java.awt.Component.dispatchEvent(Component.java:4460)                                                             
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)                                                            
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)                                 
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:178)
        at java.awt.Dialog$1.run(Dialog.java:1045)
        at java.awt.Dialog$3.run(Dialog.java:1097)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.Dialog.show(Dialog.java:1095)
        at java.awt.Component.show(Component.java:1563)
        at java.awt.Component.setVisible(Component.java:1515)
        at java.awt.Window.setVisible(Window.java:841)
        at java.awt.Dialog.setVisible(Dialog.java:985)
        at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:78)
        at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:39)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
        at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
        at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1225)
        at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1266)
        at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
        at java.awt.Component.processMouseEvent(Component.java:6263)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
        at java.awt.Component.processEvent(Component.java:6028)
        at java.awt.Container.processEvent(Container.java:2041)
        at java.awt.Component.dispatchEventImpl(Component.java:4630)
        at java.awt.Container.dispatchEventImpl(Container.java:2099)
        at java.awt.Component.dispatchEvent(Component.java:4460)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
        at java.awt.Container.dispatchEventImpl(Container.java:2085)
        at java.awt.Window.dispatchEventImpl(Window.java:2475)
        at java.awt.Component.dispatchEvent(Component.java:4460)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (1)

preferences.bz2 (2.0 KB) - added by phobie 11 years ago.
edited josm preferences file

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by phobie

Attachment: preferences.bz2 added

edited josm preferences file

comment:1 Changed 11 years ago by jttt

Owner: changed from team to jttt

comment:2 Changed 11 years ago by jttt

Resolution: fixed
Status: newclosed

Fixed in r1818

comment:3 Changed 10 years ago by jttt

Ticket #2967 has been marked as a duplicate of this ticket.

comment:4 Changed 10 years ago by stoecker

Ticket #3100 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jttt.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.