Modify

Opened 10 years ago

Closed 10 years ago

#2883 closed defect (fixed)

WMS plugin broken, URL is missing separator &

Reported by: plerner Owned by: team
Priority: critical Milestone:
Component: Core imagery Version: latest
Keywords: misspelled url Cc:

Description

http://labs.metacarta.com/rectifier/wms.cgi?id=1234&srs=EPSG:4326&Service=WMS&Version=1.1.0&Request=GetMap&format=image/pngbbox=11.5814300,49.9452996,11.5875545,49.9514241&width=500&height=500

should be

http://labs.metacarta.com/rectifier/wms.cgi?id=1234&srs=EPSG:4326&Service=WMS&Version=1.1.0&Request=GetMap&format=image/png&bbox=11.5814300,49.9452996,11.5875545,49.9514241&width=500&height=500

note the '&' before bbox

Image couldn't be fetched: http://labs.metacarta.com/rectifier/wms.cgi?id=1234&srs=EPSG:4326&Service=WMS&Version=1.1.0&Request=GetMap&format=image/pngbbox=11.58
14300,49.9452996,11.5875545,49.9514241&width=500&height=500

at wmsplugin.WMSGrabber.fetch(WMSGrabber.java:70)
at wmsplugin.Grabber.attempt(Grabber.java:68)
at wmsplugin.WMSGrabber.run(WMSGrabber.java:49)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (8)

comment:1 Changed 10 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by stoecker

Closed as duplicate of #2881.

comment:3 in reply to:  2 Changed 10 years ago by plerner

Priority: majorcritical
Resolution: duplicate
Status: closedreopened

Replying to stoecker:

Closed as duplicate of #2881.

the labs.metacarta.com URL is not in the config file

mirror_http_svn.openstreetmap.org_applications_editors_josm_plugins_wmsplugin_sources.cfg

I also completely removed the wmsplugin, deleted the plugin directory+cfgfile, and then after re-downloading, had the same buggy URL again.

How can I change this?

comment:4 Changed 10 years ago by plerner

same problem with URL to warper.geothings.net

comment:5 Changed 10 years ago by anonymous

BTW: Workaround is to add the missing & to the URL.

And yes, the problem is still there in latest. Also when pasting URLs into the Rectify dialog, they won't work unless you manually add the &.

comment:6 Changed 10 years ago by stoecker

Where do you get the URL's without the '&'?

comment:7 Changed 10 years ago by anonymous

This is the wrong code .... can you add the '&' at the end of the metacarta link.

Add default services
services.add(

new rectifierService("Metacarta Map Rectifier",

"http://labs.metacarta.com/rectifier/",
"http://labs.metacarta.com/rectifier/wms.cgi?id=__s__&srs=EPSG:4326"
+ "&Service=WMS&Version=1.1.0&Request=GetMap&format=image/png",
This matches more than the "classic" WMS link, so users can pretty much
copy any link as long as it includes the ID
"labs
.metacarta
.com/(?:.*?)(?:/|=)([0-9]+)(?:
?|/|
.|$)",
"[0-9]+$")

);
services.add(

TODO: Change all links to mapwarper.net once the project has moved.
The RegEx already matches the new URL and old URLs will be forwarded
to make the transition as smooth as possible for the users
new rectifierService("Geothings Map Warper",

"http://warper.geothings.net/",
"http://warper.geothings.net/maps/wms/__s__?request=GetMap&version=1.1.1"
+ "&styles=&format=image/png&srs=epsg:4326&exceptions=application/vnd.ogc.se_inimage",
This matches more than the "classic" WMS link, so users can pretty much
copy any link as long as it includes the ID
"(?:mapwarper
.net|warper
.geothings
.net)/(?:.*?)/([0-9]+)(?:
?|/|
.|$)",
"[0-9]+$")

);

comment:8 Changed 10 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.