Modify

Opened 13 years ago

Closed 13 years ago

#2850 closed defect (fixed)

[PATCH] unhandled Exception when trying to download data while offline

Reported by: Cobra Owned by: dmuecke
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I just had some network outage and tried to fetch some data when this error popped up:
(josm was run on ubuntu 8.04 with sun java 6)

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1738
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1738
Last Changed Date: 2009-07-05 19:42:18 +0200 (Sun, 05 Jul 2009)


Memory Usage: 109 MB / 1016 MB (22 MB allocated, but free)
Java version: 1.6.0_07

Plugins: Intersect_wayPicLayermeasurementmultipolyopenstreetbugsremotecontrolusertoolsutilspluginvalidatorwmsplugin
Plugin Intersect_way Version: 12781
Plugin PicLayer Version: 16302
Plugin measurement Version: 16317
Plugin multipoly Version: ${version.entry.commit.revision}
Plugin openstreetbugs Version: 16294
Plugin remotecontrol Version: 16290
Plugin usertools Version: 14125
Plugin utilsplugin Version: 16162
Plugin validator Version: 16346
Plugin wmsplugin Version: 16351


java.lang.RuntimeException: java.lang.RuntimeException: org.openstreetmap.josm.io.OsmTransferException: Verbindung zum OSM-Server fehlgeschlagen. Bitte prüfen sie ihre Internetverbindung.
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:120)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Caused by: java.lang.RuntimeException: org.openstreetmap.josm.io.OsmTransferException: Verbindung zum OSM-Server fehlgeschlagen. Bitte prüfen sie ihre Internetverbindung.
	at org.openstreetmap.josm.io.BoundingBoxDownloader.parseRawGps(BoundingBoxDownloader.java:84)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadGpsTask$Task.realRun(DownloadGpsTask.java:40)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:144)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
	at java.lang.Thread.run(Thread.java:619)
Caused by: org.openstreetmap.josm.io.OsmTransferException: Verbindung zum OSM-Server fehlgeschlagen. Bitte prüfen sie ihre Internetverbindung.
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:75)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:45)
	at org.openstreetmap.josm.io.BoundingBoxDownloader.parseRawGps(BoundingBoxDownloader.java:51)
	... 9 more
Caused by: java.net.UnknownHostException: www.openstreetmap.org
	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
	at java.net.Socket.connect(Socket.java:519)
	at sun.net.NetworkClient.doConnect(NetworkClient.java:152)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
	at sun.net.www.http.HttpClient.<init>(HttpClient.java:233)
	at sun.net.www.http.HttpClient.New(HttpClient.java:306)
	at sun.net.www.http.HttpClient.New(HttpClient.java:323)
	at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:788)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:729)
	at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:654)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:73)
	... 11 more

This is reproduceable by interrupting your network connection and then trying to download data.

Attachments (1)

transfer.txt (2.0 KB) - added by dmuecke 13 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 13 years ago by dmuecke

Owner: changed from team to dmuecke
Status: newassigned

Changed 13 years ago by dmuecke

Attachment: transfer.txt added

comment:2 Changed 13 years ago by dmuecke

Summary: unhandled Exception when trying to download data while offline[PATCH] unhandled Exception when trying to download data while offline

comment:3 Changed 13 years ago by Gubaer

Resolution: fixed
Status: assignedclosed

applied in r1835

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dmuecke.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.