Modify

Opened 13 years ago

Closed 13 years ago

#2741 closed defect (fixed)

exception after inserting a local WMS server in WMS plugin configuration

Reported by: umehlig Owned by: team
Priority: major Milestone:
Component: Core imagery Version:
Keywords: Cc:

Description

After inserting a local WMS server URL in the WMS plugin's configuration dialog (Preferences), JOSM triggers an exception when closing the Preferences dialog window.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1669
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1669
Last Changed Date: 2009-06-14 17:34:52 +0200 (Sun, 14 Jun 2009)

Java version: 1.6.0_0
Plugins: DirectUploadcolorschemeeditgpxlakewalkermeasurementmultipolyopenstreetbugsopenvisibleroutesroutingslippymaptageditortagging-preset-testerusertoolsutilspluginvalidatorwaydownloaderwmsplugin
Plugin DirectUpload Version: 15828
Plugin colorscheme Version: 14233
Plugin editgpx Version: 15678
Plugin lakewalker Version: 14015
Plugin measurement Version: 14015
Plugin multipoly Version: ${version.entry.commit.revision}
Plugin openstreetbugs Version: 14826
Plugin openvisible Version: 15707
Plugin routes
Plugin routing Version: 15710
Plugin slippymap Version: 15707
Plugin tageditor Version: 15707
Plugin tagging-preset-tester Version: 14015
Plugin usertools Version: 14125
Plugin utilsplugin Version: 15127
Plugin validator Version: 15127
Plugin waydownloader Version: 15707
Plugin wmsplugin Version: 15890

java.lang.NullPointerException

at org.openstreetmap.josm.plugins.PluginSelection.finish(PluginSelection.java:111)
at org.openstreetmap.josm.gui.preferences.PluginPreference.ok(PluginPreference.java:116)
at org.openstreetmap.josm.gui.preferences.PreferenceDialog.ok(PreferenceDialog.java:93)
at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:79)
at java.lang.Thread.run(Thread.java:636)

Attachments (0)

Change History (2)

comment:1 Changed 13 years ago by stoecker

Ticket #2742 has been marked as a duplicate of this ticket.

comment:2 Changed 13 years ago by stoecker

Resolution: fixed
Status: newclosed

Fix in r1671.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.