Modify

Opened 15 years ago

Closed 15 years ago

#2670 closed defect (fixed)

java.net.MalformedURLException: no protocol: /

Reported by: phobie Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: exception BoundingBoxDownloader MalformedURL remotecontrol Cc:

Description

Revision: 1621
CMD-Line: java -Xmx1024M -Dsun.java2d.opengl=True -jar josm-latest.jar
OS: Debian/sid

After removing ~/.josm/ the error disappeared.
BTW. The splash-screen stays open for several minutes until the main-window opens! Probably a problem of the remotecontrol plugin.

Log:

OpenGL pipeline enabled for default config on screen 0
loading plastic_laf
loading remotecontrol
java.net.BindException: Cannot assign requested address

at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
at java.net.ServerSocket.bind(ServerSocket.java:319)
at java.net.ServerSocket.<init>(ServerSocket.java:185)
at org.openstreetmap.josm.plugins.remotecontrol.HttpServer.<init>(HttpServer.java:37)
at org.openstreetmap.josm.plugins.remotecontrol.RemoteControlPlugin.restartServer(RemoteControlPlugin.java:43)
at org.openstreetmap.josm.plugins.remotecontrol.RemoteControlPlugin.<init>(RemoteControlPlugin.java:22)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
at java.lang.Class.newInstance0(Class.java:355)
at java.lang.Class.newInstance(Class.java:308)
at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:155)
at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:148)
at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:170)

loading slippymap
loading usertools
loading validator
loading wmsplugin
org.openstreetmap.josm.io.OsmTransferException: java.net.MalformedURLException: no protocol: /

at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:544)
at org.openstreetmap.josm.io.OsmApi.initialize(OsmApi.java:141)
at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:47)
at org.openstreetmap.josm.io.BoundingBoxDownloader.parseOsm(BoundingBoxDownloader.java:96)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$Task.realRun(DownloadOsmTask.java:53)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:101)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

Caused by: java.net.MalformedURLException: no protocol: /

at java.net.URL.<init>(URL.java:567)
at java.net.URL.<init>(URL.java:464)
at java.net.URL.<init>(URL.java:413)
at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:458)
... 11 more

Attachments (1)

preferences.gz (1.2 KB ) - added by phobie 15 years ago.
josm preferences file

Download all attachments as: .zip

Change History (7)

comment:1 by stoecker, 15 years ago

Owner: changed from team to phobie
Status: newneedinfo

Do you still have your preferences file? If yes, pleaee attach it (strip username/password).

by phobie, 15 years ago

Attachment: preferences.gz added

josm preferences file

comment:2 by phobie, 15 years ago

Status: needinfoassigned

$ dpkg -l sun-java6-bin
ii sun-java6-bin 6-13-1

$ java -version
java version "1.6.0_13"
Java(TM) SE Runtime Environment (build 1.6.0_13-b03)
Java HotSpot(TM) Server VM (build 11.3-b02, mixed mode)

comment:3 by stoecker, 15 years ago

Component: CorePlugin
Owner: changed from phobie to team
Status: assignednew
Summary: BoundingBoxDownloader failed: org.openstreetmap.josm.io.OsmTransferException: java.net.MalformedURLException: no protocol: /Remotecontrol plugins: Trouble after binding port fails

comment:4 by phobie, 15 years ago

Component: PluginCore
Summary: Remotecontrol plugins: Trouble after binding port failsjava.net.MalformedURLException: no protocol: /

Still present in 1679!

After a "rm -rf ~/.josm" it always works for some time.
I can also restart JOSM without problems.
But if I restart it after using it several hours I'll get the error again.

sun-java6-bin 6-14-1

$ java -version
java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) Server VM (build 14.0-b16, mixed mode)


Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1679
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 1679
Last Changed Date: 2009-06-17 18:21:46 +0200 (Wed, 17 Jun 2009)

Memory Usage: 55 MB / 986 MB (35 MB allocated, but free)
Java version: 1.6.0_14

java.lang.RuntimeException: java.lang.RuntimeException: org.openstreetmap.josm.io.OsmApiInitializationException: org.openstreetmap.josm.io.OsmTransferException: java.net.MalformedURLException: no protocol: /

at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:127)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Caused by: java.lang.RuntimeException: org.openstreetmap.josm.io.OsmApiInitializationException: org.openstreetmap.josm.io.OsmTransferException: java.net.MalformedURLException: no protocol: /

at org.openstreetmap.josm.io.BoundingBoxDownloader.parseRawGps(BoundingBoxDownloader.java:84)
at org.openstreetmap.josm.actions.downloadtasks.DownloadGpsTask$Task.realRun(DownloadGpsTask.java:40)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:102)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

Caused by: org.openstreetmap.josm.io.OsmApiInitializationException: org.openstreetmap.josm.io.OsmTransferException: java.net.MalformedURLException: no protocol: /

at org.openstreetmap.josm.io.OsmApi.initialize(OsmApi.java:183)
at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:43)
at org.openstreetmap.josm.io.BoundingBoxDownloader.parseRawGps(BoundingBoxDownloader.java:51)
... 8 more

Caused by: org.openstreetmap.josm.io.OsmTransferException: java.net.MalformedURLException: no protocol: /

at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:460)
at org.openstreetmap.josm.io.OsmApi.initialize(OsmApi.java:163)
... 10 more

Caused by: java.net.MalformedURLException: no protocol: /

at java.net.URL.<init>(URL.java:567)
at java.net.URL.<init>(URL.java:464)
at java.net.URL.<init>(URL.java:413)
at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:377)
... 11 more


comment:5 by phobie, 15 years ago

I found out that this bug is triggered by a missing "osm-server.url"-variable in the ~/.josm/preferences file.
Sometimes JOSM removes this variable from config.
After re-adding the variable the profile is usable again!

comment:6 by stoecker, 15 years ago

Resolution: fixed
Status: newclosed

Has been fixed inbetween.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.