Modify

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#2521 closed defect (duplicate)

problems handling conflicts when two users edit the same onject

Reported by: Cobra Owned by: Cobra
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc: Gubaer

Description

I did some edits, wanted to upload them, and caused a conflict since someone else edited one of my objects while I was still working. So I refreshed data, resolved conflicts and tried again but didn't succeed in uploading; message was "Version mismatch: provided 8, Server had 9". When I saved data locally and looked at the ways causing errors I noticed that there are still informations (timestamp, user, version) of the previous version instead of the current one.

Revision is 1567 (latest josm-latest.jar as of now).

Attachments (0)

Change History (7)

comment:1 Changed 10 years ago by Cobra

I saved all data (after refreshing and resolving conflicts) locally and uploaded that file here: http://home.arcor.de/SLXViper/osm/data.osm

comment:2 Changed 10 years ago by Gubaer

Cc: Gubaer added
Owner: changed from team to Cobra
Status: newneedinfo

For which element did you get "Version mismatch: provided 8, Server had 9"? The error message should also include an element id. Was it a relation?

comment:3 Changed 10 years ago by Cobra

Output on terminal is:

PUT http://www.openstreetmap.org/api/0.6/changeset/create... OK
POST http://www.openstreetmap.org/api/0.6/changeset/1071589/upload... Conflict
Error body: Version mismatch: Provided 8, server had: 9 of Way 27010139

PUT http://www.openstreetmap.org/api/0.6/changeset/1071589/close... OK

comment:4 Changed 10 years ago by Gubaer

Way 27010139 (Version 8) is a complex update of Way 27010139 (Version 9):

  • Way 27010139 (Version 8) includes more nodes
  • some nodes (i.e. Node 296060414) have been removed from Way 27010139 (Version 8) (they are deleted in the local data set)

It seems that JOSM doesn't support conflict resolution for this case yet. It's similar to missing conflict resolution in relations, see #2512.

comment:5 Changed 10 years ago by anonymous

Priority: criticalblocker

comment:6 Changed 9 years ago by stoecker

Resolution: duplicate
Status: needinfoclosed

comment:7 Changed 9 years ago by stoecker

Closed as duplicate of #2609.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Cobra.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.