Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2493 closed defect (duplicate)

deleting duplicate way fails with Nullpointerexeption

Reported by: anonymous Owned by: team
Priority: blocker Milestone:
Component: Core Version:
Keywords: Cc:

Description

deleting duplicate way often fails.

Try deleting way 33140825 in current JOSM and upload the result. You'll get a Nullpointerexeption! I already deleted 3 copys of this way which works, but this forth
copy doesn't work.

To find out the way#, I tried to delete all ways/nodes (exept the one i wanted to look at) in JOSM witch crashed again, but this time with an erroemessage:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1565
Node Kind: directory
Last Changed Author: ulfl
Last Changed Rev: 1565
Last Changed Date: 2009-04-28 23:12:48 +0200 (Tue, 28 Apr 2009)

Java version: 1.6.0_13
Plugins: AgPifoJ;Create_grid_of_ways;DirectUpload;Intersect_way;PicLayer;colorscheme;editgpx;lanetool;measurement;multipoly;openstreetbugs;openvisible;plastic_laf;remotecontrol;slippymap;tageditor;terracer;usertools;utilsplugin;validator;wmsplugin
Plugin plastic_laf Version: 14016
Plugin AgPifoJ Version: 14290
Plugin Create_grid_of_ways Version: 12782
Plugin DirectUpload Version: 14133
Plugin Intersect_way Version: 12781
Plugin PicLayer Version: 14839
Plugin colorscheme Version: 14233
Plugin editgpx Version: 14247
Plugin lanetool Version: 10907
Plugin measurement Version: 14015
Plugin multipoly Version: ${version.entry.commit.revision}
Plugin openstreetbugs Version: 14826
Plugin openvisible Version: 14233
Plugin remotecontrol Version: 14015
Plugin slippymap Version: 14732
Plugin tageditor Version: 14839
Plugin terracer Version: 14048
Plugin usertools Version: 14125
Plugin utilsplugin Version: 14356
Plugin validator Version: 14406
Plugin wmsplugin Version: 14120

java.lang.ArrayIndexOutOfBoundsException: -1

at java.util.ArrayList.get(Unknown Source)
at org.openstreetmap.josm.data.osm.Way.lastNode(Way.java:176)
at org.openstreetmap.josm.data.osm.Way.removeNode(Way.java:136)
at org.openstreetmap.josm.data.osm.Way.removeNodes(Way.java:154)
at org.openstreetmap.josm.command.DeleteCommand.delete(DeleteCommand.java:234)
at org.openstreetmap.josm.actions.mapmode.DeleteAction.doActionPerformed(DeleteAction.java:81)
at org.openstreetmap.josm.actions.DeleteAction.actionPerformed(DeleteAction.java:29)
at javax.swing.SwingUtilities.notifyAction(Unknown Source)
at javax.swing.JComponent.processKeyBinding(Unknown Source)
at javax.swing.KeyboardManager.fireBinding(Unknown Source)
at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
at javax.swing.JComponent.processKeyBindings(Unknown Source)
at javax.swing.JComponent.processKeyEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by anonymous

Summary: deleting duplicate way often fails.deleting duplicate way fails with Nullpointerexeption

comment:2 Changed 10 years ago by anonymous

Priority: majorblocker
Resolution: duplicate
Status: newclosed

comment:3 Changed 10 years ago by anonymous

Closed as duplicate of #2523.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.