Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2449 closed defect (duplicate)

conflict when uploading changes after splitting way / one half of the way should remain on relation route, other half off relation route

Reported by: plerner Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: relation, split way within relation Cc: peter@…

Description

I've split a way which was part of a route. Only one half of the way should remain part of the route, second half should be off the route.

Upload with JOSM (API 0.6) fails. After new Download/Update of region JOSM is not able to resolve conflict. Message is "0 conflicts in 1 object resolved".

Problem is IMHO in route "Ostsee-Oberbayern" (see attachement).

I worked with josm v1537, when I've seen this error first. Then I tried to upload again with josm v1546 and failed again.

Could anyone help? Changes are not yet uploaded. I don't to losse them.

Peter

Attachments (3)

josm upload split.zip (110.6 KB) - added by plerner 10 years ago.
JOSM saved changes / not yet uploaded due to conflict
josm upload split.z01 (200.0 KB) - added by plerner 10 years ago.
asbach.osm.zip (56.1 KB) - added by vpaul 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by plerner

Attachment: josm upload split.zip added

JOSM saved changes / not yet uploaded due to conflict

Changed 10 years ago by plerner

Attachment: josm upload split.z01 added

comment:1 Changed 10 years ago by plerner

Priority: criticalblocker

comment:2 Changed 10 years ago by plerner

Cc: peter@… added

Maybe not directly related, but exception appeared while resolving conflicts.

GET http://www.openstreetmap.org/api/capabilities... OK
Communications with http://www.openstreetmap.org/api established using protocol version 0.6
Exception occurred during event dispatching:
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0

at java.util.ArrayList.RangeCheck(Unknown Source)
at java.util.ArrayList.get(Unknown Source)
at org.openstreetmap.josm.gui.ConflictResolver$ResolveAction.actionPerformed(ConflictResolver.java:113)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.ExtendedDialog.<init>(ExtendedDialog.java:48)
at org.openstreetmap.josm.gui.dialogs.ConflictDialog.resolve(ConflictDialog.java:120)
at org.openstreetmap.josm.gui.dialogs.ConflictDialog.access$100(ConflictDialog.java:48)
at org.openstreetmap.josm.gui.dialogs.ConflictDialog$2.actionPerformed(ConflictDialog.java:66)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

GET http://www.openstreetmap.org/api/capabilities... OK
Communications with http://www.openstreetmap.org/api established using protocol version 0.6

Changed 10 years ago by vpaul

Attachment: asbach.osm.zip added

comment:3 Changed 10 years ago by anonymous

Don't know if related, but I had the following error message:

Communications with http://www.openstreetmap.org/api established using protocol version 0.6
PUT http://www.openstreetmap.org/api/0.6/changeset/create... OK
POST http://www.openstreetmap.org/api/0.6/changeset/979859/upload... Internal Server Error
POST http://www.openstreetmap.org/api/0.6/changeset/979859/upload... Conflict
PUT http://www.openstreetmap.org/api/0.6/changeset/979859/close... OK

The problem is not related to 0.5 data, as I downloaded the region after
the 0.6 transition. There are no validation errors or conflicts, both panels are empty.

When I later tried again to upload, no "Internal Server Error" appeared, but only "Conflict":

Communications with http://www.openstreetmap.org/api established using protocol version 0.6
PUT http://www.openstreetmap.org/api/0.6/changeset/create... OK
POST http://www.openstreetmap.org/api/0.6/changeset/980159/upload... Conflict
PUT http://www.openstreetmap.org/api/0.6/changeset/980159/close... OK

Will try to attach asbach.osm.zip.

Using JOSM 1529.

comment:4 Changed 10 years ago by Bhatarsaigh

As this ticket has a higher prio I'll post my problem here as well as it is related to the topic.

I seem to have the same problem with solving conflicting relations: http://forum.openstreetmap.org/viewtopic.php?id=3171

comment:5 Changed 10 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:6 Changed 10 years ago by stoecker

Closed as duplicate of #2609.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.