Modify

Opened 10 years ago

Closed 10 years ago

#2419 closed defect (fixed)

[Patch] motd.html cache doesn't expire when switching languages

Reported by: avarab@… Owned by: team
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

When I switch languages, e.g. from German to Icelandic I might end up with an Icelandic UI and a German MOTD.

This happens because the MOTD is cached in ~/.josm/motd.html and refreshed daily, regardless of whether the UI language has been changed in the meantime.

Attachments (1)

LanguageFix.patch (1.4 KB) - added by xeen 10 years ago.
Watch for language changes also

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by xeen

Attachment: LanguageFix.patch added

Watch for language changes also

comment:1 Changed 10 years ago by xeen

Summary: motd.html cache doesn't expire when switching languages[Patch] motd.html cache doesn't expire when switching languages

comment:2 Changed 10 years ago by stoecker

Ticket #2466 has been marked as a duplicate of this ticket.

comment:3 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

Fixed in r1562.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.