Modify

Opened 5 weeks ago

Closed 3 days ago

#23676 closed defect (fixed)

NumberFormatException in MapillaryImageUtils.getKey

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Loading the Mapillary Imagery
  2. Loading a geojson data file for buildings

What is the expected result?

Loading the Geojson file with Mapillary images

What happens instead?

Shows a bug report

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2024-04-29 18:37:36 +0200 (Mon, 29 Apr 2024)
Revision:19067
Build-Date:2024-05-02 01:31:13
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (19067 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 22H2 (19045)
Memory Usage: 1286 MB / 2012 MB (642 MB allocated, but free)
Java version: 21.0.2+13-LTS-58, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.25×1.25)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: UTF-8
System property sun.jnu.encoding: Cp1252
Locale info: en_US
Numbers with default locale: 1234567890 -> 1234567890
Dataset consistency test: No problems found

Plugins:
+ Mapillary (3904)
+ apache-commons (36176)
+ mapathoner (1.5.5)
+ mapwithai (829)
+ pmtiles (36219)
+ todo (137)
+ utilsplugin2 (36226)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1
- %UserProfile%\Downloads\Compressed\applepaintstyles-main.zip

Last errors/warnings:
- 01608.239 E: Handled by bug report queue: java.lang.NumberFormatException: For input string: "whgj0e5GZm4znJ1QDSV9ct"
- 01612.970 E: Handled by bug report queue: java.lang.NumberFormatException: For input string: "frqClFTLEaW7n6KGJxkuOc"
- 01614.023 E: Handled by bug report queue: java.lang.NumberFormatException: For input string: "ojcrPgObpCdTGNeJDv6fz7"
- 01618.541 E: Handled by bug report queue: java.lang.NumberFormatException: For input string: "whgj0e5GZm4znJ1QDSV9ct"
- 01634.725 E: Handled by bug report queue: java.lang.NumberFormatException: For input string: "frqClFTLEaW7n6KGJxkuOc"
- 01644.504 W: java.net.SocketTimeoutException: Read timed out
- 01658.112 W: Warning - <html>Cannot open 1 file because file does not exist or no suitable file importer is available.<br><ul><li>E:\Nateete\New folder\natetebuildingsfeatures201.qmd (<i>no importer</i>)</li></ul></html>
- 01660.039 W: java.util.zip.ZipException: zip END header not found
- 01660.039 W: PluginException: : org.openstreetmap.josm.plugins.PluginException: Invalid jar file '<josm.pref>\plugins\utilsplugin2.jar.new'
- 01660.040 W: Failed to scan file 'utilsplugin2.jar.new' for plugin information. Skipping.



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: MVT-downloader-13 (126)
java.lang.NumberFormatException: For input string: "efL4A5RFgUjclwn73byMtJ"
	at java.base/java.lang.NumberFormatException.forInputString(NumberFormatException.java:67)
	at java.base/java.lang.Long.parseLong(Long.java:709)
	at java.base/java.lang.Long.parseLong(Long.java:832)
	at org.openstreetmap.josm.plugins.mapillary.utils.MapillaryImageUtils.getKey(MapillaryImageUtils.java:259)
	at org.openstreetmap.josm.plugins.mapillary.gui.layer.MapillaryLayer.lambda$finishedLoading$9(MapillaryLayer.java:781)
	at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:184)
	at java.base/java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:179)
	at java.base/java.util.HashMap$KeySpliterator.forEachRemaining(HashMap.java:1715)
	at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509)
	at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499)
	at java.base/java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151)
	at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174)
	at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
	at java.base/java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:596)
	at org.openstreetmap.josm.plugins.mapillary.gui.layer.MapillaryLayer.finishedLoading(MapillaryLayer.java:781)
	at org.openstreetmap.josm.data.imagery.vectortile.mapbox.MVTTile.lambda$loadImage$0(MVTTile.java:73)
	at org.openstreetmap.josm.tools.ListenerList.fireEvent(ListenerList.java:162)
	at org.openstreetmap.josm.data.imagery.vectortile.mapbox.MVTTile.loadImage(MVTTile.java:73)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.tryLoadTileImage(TMSCachedTileLoaderJob.java:328)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.loadingFinished(TMSCachedTileLoaderJob.java:210)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.finishLoading(JCSCachedTileLoaderJob.java:265)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:234)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1144)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:642)
	at java.base/java.lang.Thread.run(Thread.java:1583)

Attachments (1)

WhatsApp Image 2024-05-13 at 10.06.42_d3c988ce.jpg (86.9 KB ) - added by KALUBA MICHEAL 5 weeks ago.
Bug

Download all attachments as: .zip

Change History (6)

by KALUBA MICHEAL, 5 weeks ago

Bug

comment:1 by skyper, 5 weeks ago

Component: CorePlugin mapillary
Owner: changed from team to taylor.smock
Priority: majornormal
Version: latest

comment:2 by taylor.smock, 5 weeks ago

Owner: changed from taylor.smock to anonymous
Status: newneedinfo

@KALUBA MICHEAL: Can you provide a sample file and/or location? There should be no instances where an id for a Mapillary image is a string (which is what is causing the crash). I'll want to check the actual API response in the problem area so I can figure out what the problem is.

comment:3 by taylor.smock, 5 weeks ago

Summary: The Latest Version of JOSM is CrushingNumberFormatException in MapillaryImageUtils.getKey

comment:4 by taylor.smock, 3 days ago

Ticket #23734 has been marked as a duplicate of this ticket.

comment:5 by taylor.smock, 3 days ago

Resolution: fixed
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.