Modify

Opened 8 months ago

Closed 8 months ago

#23254 closed enhancement (duplicate)

Wrong Visualisation of the width of the carriageway when using the Lanes and Road Attributes mappaint style

Reported by: der_eine_lauch Owned by: team
Priority: normal Milestone:
Component: External mappaint style Version:
Keywords: template_report, Lanes and Road Attributes mappaint style Cc:

Description

What steps will reproduce the problem?

  1. When specifying a value for width:lane, the actual width of the lane is not displayed correctly in the Lanes and Road Attributes mappaint style.

What is the expected result?

That it shows the lanes exactly in the width they have. When I measure the visualized width of the lane with the measurement plugin, it should give the same width that I entered.

What happens instead?

For a three lane road, I added: width:lanes=3.8|3.8|3.8 (as documented here). When I measure the width with the measurement plugin, it says that each lane is 3.05 m wide although it is actually 3.8 m wide.

Please provide any additional information below. Attach a screenshot if possible.

In this screenshot you can see that I added width:lanes=3.8|3.8|3.8 to this segment. When I measure the width of the first lane with the measurement plugin (thin green line), the result is that the width is 3.05m.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2023-08-29 13:38:40 +0200 (Tue, 29 Aug 2023)
Revision:18822
Build-Date:2023-08-30 01:30:57
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (18822 de) Windows 10 64-Bit
OS Build number: Windows 10 Home 2009 (19045)
Memory Usage: 1095 MB / 2026 MB (581 MB allocated, but free)
Java version: 17.0.7+7-LTS, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00) \Display1 1440×900 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: de_DE
Numbers with default locale: 1234567890 -> 1234567890
VM arguments: [-Dicedtea-web.bin.location=%UserProfile%\AppData\Local\Programs\OpenWebStart\javaws, -Djava.util.Arrays.useLegacyMergeSort=true, --add-exports=jdk.deploy/com.sun.deploy.config=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-reads=java.base=ALL-UNNAMED,java.desktop, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-exports=java.desktop/com.apple.eawt=ALL-UNNAMED, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-exports=javafx.graphics/com.sun.javafx.application=ALL-UNNAMED, --add-modules=java.scripting,java.sql,javafx.controls,javafx.media,javafx.swing,javafx.web, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop,jdk.jsobject, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-opens=java.base/java.nio=ALL-UNNAMED, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop]
Dataset consistency test: No problems found

Plugins:
+ Mapillary (2.2.0)
+ apache-commons (36034)
+ apache-http (35924)
+ continuosDownload (102)
+ ejml (35924)
+ geotools (36068)
+ jackson (36034)
+ jaxb (36118)
+ jna (36126)
+ jts (36004)
+ measurement (36126)
+ opendata (36126)
+ public_transport (36126)
+ tageditor (36126)
+ turnlanes-tagging (0.0.5)
+ undelete (36126)
+ utilsplugin2 (36134)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/MapillaryDetections&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- 00000.457 W: extended font config - overriding 'filename.Myanmar_Text=mmrtext.ttf' with 'MMRTEXT.TTF'
- 00000.460 W: extended font config - overriding 'filename.Mongolian_Baiti=monbaiti.ttf' with 'MONBAITI.TTF'
- 00004.137 W: Unable to request certificate of https://roottest-g3.pkioverheid.nl
- 00004.619 W: Unable to request certificate of https://roottest-g3.pkioverheid.nl
- 01340.903 W: java.net.SocketException: Socket closed. Ursache: java.net.SocketException: Socket closed
- 01340.905 E: java.net.SocketException: Socket closed. Ursache: java.net.SocketException: Socket closed

Attachments (1)

Screenshot 2023-10-30 145756.jpg (204.0 KB ) - added by der_eine_lauch 8 months ago.
Screenshot in JOSM

Download all attachments as: .zip

Change History (4)

by der_eine_lauch, 8 months ago

Screenshot in JOSM

comment:1 by taylor.smock, 8 months ago

Component: Core mappaintExternal mappaint style
Resolution: duplicate
Status: newclosed

Closed as duplicate of #8588.
From wiki:Styles/Lane_and_Road_Attributes, the style uses "[pixel] per metre (on average)". So it is on average correct. Unfortunately, the further you get away from where the average is "correct", the more of a difference there is between the average and the actual pixels per metre.

comment:2 by der_eine_lauch, 8 months ago

Resolution: duplicate
Status: closedreopened
Type: defectenhancement

Okay, thank you. But can this please be updated because it would be very useful if it is visualized in actual size.
Until this happens, it would be good to add this information to the documentation of this style, because I'm probably not the only one confused by this.

comment:3 by taylor.smock, 8 months ago

Resolution: duplicate
Status: reopenedclosed

Until this happens, it would be good to add this information to the documentation of this style

It is already in the documentation for the style (just not in the description, which is of limited length since otherwise people won't read it).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.