Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#23204 closed defect (invalid)

Shortcut Alt+r doesn't work to switch building to rectangular mode (Alt+z works for circular)

Reported by:… Owned by:…
Priority: normal Milestone:
Component: Plugin buildings_tools Version:
Keywords: template_report Cc:


What steps will reproduce the problem?

  1. open a HOT project with JOSM
  2. see that you are in building mode with circular shape so press Alt+r to switch to rectangular mode
  3. observe that building mode is still circular a) by building something and b) by observing that the little shape near the mouse hasn't changed to the icon meaning "rectangular mode"

What is the expected result?

The expected result is that Alt+r will switch building mode from circular to rectangular

What happens instead?

Building mode stays in rectangular

Please provide any additional information below. Attach a screenshot if possible.

Additionally observed:

  • switching between rectangular and circular building modes is possible via GUI menu, just not via shortcut
  • when having switched by GUI to rectangular building mode, Alt+z works to switch to circular building mode, but from there Alt+r doesn't switch back to rectangular mode again
Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2023-08-29 13:38:40 +0200 (Tue, 29 Aug 2023)
Build-Date:2023-08-30 01:30:57

Identification: JOSM/1.5 (18822 en) Linux Mint 19 Tara
Memory Usage: 1288 MB / 3976 MB (650 MB allocated, but free)
Java version: 11.0.19+7-post-Ubuntu-0ubuntu118.04.1, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel:
Screen: :0.0 1920×1080 (scaling 1.00×1.00) :0.1 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: en_US.UTF-8
Environment variable LC_ALL: 
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: en_US
Numbers with default locale: 1234567890 -> 1234567890
Desktop environment: X-Cinnamon
Java package: openjdk-11-jre:amd64-11.0.19+7~us1-0ubuntu1~18.04.1
fonts-noto: fonts-noto:all-20171026-2
VM arguments: [--module-path=/usr/share/openjfx/lib, --add-modules=java.scripting,java.sql,javafx.controls,,javafx.swing,javafx.web, -Djosm.restart=true,, --add-exports=java.base/, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED]
Dataset consistency test: No problems found

+ buildings_tools (36134)
+ terracer (36126)
+ utilsplugin2 (36134)

Tagging presets:

Last errors/warnings:
- 00004.240 W: Update plugins - You updated your JOSM software. To prevent problems the plugins should be updated as well.  Update plugins now?
- 04131.607 W: Terracer: wrong or missing outline
- 04518.273 E: Failed to locate image '[[Image(pond.png)]]'
- 04518.310 E: Failed to locate image '[[Image(oil-palm.png)]]'

Attachments (0)

Change History (5)

comment:1 Changed 2 months ago by…

Might be related to this ticket, not sure:

comment:2 Changed 2 months ago by taylor.smock

Owner: changed from Upliner to…
Status: newneedinfo

It works for me on macOS and Fedora 38 Silverblue (GNOME). Maybe cinnamon is intercepting the keyevent?

Can you try under a different desktop environment? Specifically GNOME, since I know it works under Fedora 38 GNOME (I checked against GNOME classic as well). I also tried under X and Wayland sessions, and both worked.

comment:3 Changed 2 months ago by…

Thank you for the suggestion!

I checked all shortcuts defined for Cinnamon - there is no shortcut defined for Alt+r. However, there was a shortcut 'Alt+r' defined in the app "Autokey" for inserting a text snippet.

Sorry to not have checked more thoroughly all the options. The ticket can be closed.

P.S. Cautionary note on others using user-defined shortcuts:
As a test I temporarily assigned the shortcut 'Alt+r' in the Cinnamon settings to a random action that didn't have any shortcut assigned to it and there was no error message that 'Alt+r' is already taken - despite the fact that the scope of Autokey insertion is not specifically limited to any app and can insert text anywhere where a keyboard can ...

comment:4 Changed 2 months ago by…

Resolution: invalid
Status: needinfoclosed

comment:5 Changed 2 months ago by taylor.smock

there was no error message that 'Alt+r' is already taken

I don't think it is currently possible for us to "see" shortcuts that are taken by other applications. As a specific example, we currently hardcode the operating system shortcuts that we know about, so that users don't try and use them.

Anyway, thank you for the bug report, even if we cannot fix it.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain….
as The resolution will be set.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.