Modify

Opened 8 months ago

Closed 7 months ago

#23025 closed defect (wontfix)

maxar tiles cannot be downloaded - invalid connect ID

Reported by: zwombie Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: template_report, stoecker Cc:

Description

What steps will reproduce the problem?

  1. using Maxar as imagery

What is the expected result?

the tiles load

What happens instead?

I get an error message

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2023-06-02 17:23:29 +0200 (Fri, 02 Jun 2023)
Revision:18746
Build-Date:2023-06-03 01:31:02
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (18746 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2009 (19045)
Memory Usage: 274 MB / 2036 MB (49 MB allocated, but free)
Java version: 17.0.7+7-LTS, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: de_DE
Numbers with default locale: 1234567890 -> 1234567890
VM arguments: [-Dicedtea-web.bin.location=%UserProfile%\AppData\Local\Programs\OpenWebStart\javaws, -Djava.util.Arrays.useLegacyMergeSort=true, --add-exports=jdk.deploy/com.sun.deploy.config=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-reads=java.base=ALL-UNNAMED,java.desktop, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-exports=java.desktop/com.apple.eawt=ALL-UNNAMED, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-exports=javafx.graphics/com.sun.javafx.application=ALL-UNNAMED, --add-modules=java.scripting,java.sql,javafx.controls,javafx.media,javafx.swing,javafx.web, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop,jdk.jsobject, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-opens=java.base/java.nio=ALL-UNNAMED, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop]
Dataset consistency test: No problems found

Plugins:
+ apache-commons (36034)
+ apache-http (35924)
+ buildings_tools (36011)
+ imagery_offset_db (36079)
+ jna (36005)
+ mapwithai (794)
+ measurement (36066)
+ reverter (36066)
+ utilsplugin2 (36079)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style

Last errors/warnings:
- 00000.465 W: extended font config - overriding 'filename.Myanmar_Text=mmrtext.ttf' with 'MMRTEXT.TTF'
- 00000.467 W: extended font config - overriding 'filename.Mongolian_Baiti=monbaiti.ttf' with 'MONBAITI.TTF'
- 00006.554 E: Fehler beim Laden des Bildes 'blue-sign-with-car.svg'
- 00006.560 W: Mappaint style "standard" (Parking lanes) icon "blue-sign-with-car.svg" not found.

Attachments (2)

screenshot maxar.JPG (25.1 KB ) - added by zwombie 8 months ago.
screenshot with maxar error message
Maxar Screenshot 2.jpg (1.2 MB ) - added by ftcat 8 months ago.
JOSM and Maxar

Download all attachments as: .zip

Change History (10)

by zwombie, 8 months ago

Attachment: screenshot maxar.JPG added

screenshot with maxar error message

comment:1 by edvac, 8 months ago

Same for me. Error with Maxar.

comment:2 by Ukundji, 8 months ago

I think that this is a global, general problem. I havethe same Maxar error message as in zwombie`s screenshot.

comment:3 by taylor.smock, 8 months ago

Keywords: stoecker added
Summary: maxar Kacheln können nicht heruntergeladen werden - invalid connect IDmaxar tiles cannot be downloaded - invalid connect ID

This affects all OSM editors (I checked both Rapid and iD). We cannot fix it until Maxar gives us updated keys, or they switch to some other kind of authentication, at which point we will probably have to implement something.

I do understand that it is annoying that Maxar is not working, but please keep in mind that there are other imagery providers. And some local governments have excellent imagery that is legally usable for OSM. Even if it isn't, you may still be able to get permission for use in OSM by asking.

by ftcat, 8 months ago

Attachment: Maxar Screenshot 2.jpg added

JOSM and Maxar

comment:4 by ftcat, 8 months ago

The problem is not universal. Some tiles will load others nearby fail, even after flushing cache See attached screenshot 'Maxar Screenshot 2' The tile info dialog is for the tile covering the sports stadium. Also differs with zoom level.

In parts of Zambia Maxar is the most up to date imagery, by many years in some cases.

comment:5 by edvac, 8 months ago

I do understand that it is annoying that Maxar is not working, but please keep in mind that there are other imagery providers.

In quite many areas of Africa - and probably in many areas elsewere -, Maxar is the reference imagery that people use. Many times, Bing is very outdated. Esri can work, but not always. If Maxar is down, mappers in many areas of the world suffer. I know that's not the case in Europe, for example.

comment:7 by gaben, 8 months ago

Ticket #23038 has been marked as a duplicate of this ticket.

comment:8 by stoecker, 7 months ago

Resolution: wontfix
Status: newclosed

Seems situation wont change.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.