Modify

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#22768 closed enhancement (duplicate)

Add shortcuts to be able to select previous search strings in the Search dialog

Reported by: pluton Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report, macos, aqualaf Cc:

Description

It would be helpful and quicker to have a few shortcuts to open and go through the previous search strings list in the Search dialog (Cmd+F). Currently, I have to use the mouse to open the strings list (or start typing, but it only suggests one item and only from the beginning).
Suggestion:

  • add a shortcut (say, F4) to open the strings list and use the up/down keys to select an item in the list (they don't work at the moment), or
  • add a shortcut to open the list and select the newest item automatically, it could be Alt+down, then use Alt+up/Alt+down to select an item in the list.

Please provide any additional information below. Attach a screenshot if possible.

Revision:18646
Build-Date:2023-01-30 15:17:59

Identification: JOSM/1.5 (18646 en) Mac OS X 12.6.3
OS Build number: macOS 12.6.3 (21G419)
Memory Usage: 4096 MB / 4096 MB (2101 MB allocated, but free)
Java version: 17.0.6+10-LTS, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69733248 1680×1050 (scaling 2.00×2.00)
Maximum Screen Size: 1680×1050
Best cursor sizes: 16×16→16×16, 32×32→32×32
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: en_US
Numbers with default locale: 1234567890 -> 1234567890
VM arguments: [-Djpackage.app-version=18646, --add-modules=java.scripting,java.sql,javafx.controls,javafx.media,javafx.swing,javafx.web, --add-exports=java.base/sun.security.action=ALL-UNNAMED, --add-exports=java.desktop/com.apple.eawt=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-opens=java.base/java.nio=ALL-UNNAMED, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, -Djpackage.app-path=/Applications/JOSM.app/Contents/MacOS/JOSM]

Attachments (0)

Change History (3)

comment:1 by taylor.smock, 16 months ago

Keywords: macos aqualaf added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #22055.
Try changing your Look and Feel from Mac OS X to Metal or any of the other LaFs, if you want to use a down arrow to navigate the list.

Otherwise, if you are using a Mac keyboard with a fn (function) button, you can try doing fn + down arrow.

comment:2 by pluton, 16 months ago

taylor.smock, thanks for the comment! fn+down works, however it is PgDown, so it scrolls by ~20 items and I can't select any items in between.
The up/down do work in other look and feels. I'll try using Nimbus for now.

comment:3 by taylor.smock, 16 months ago

At this point, I'm kind of viewing the Aqua Look and Feel as broken. There are several issues with it, one of which occurs when someone is typing in a RTL (e.g. arabic) language in the value textbox.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.