Modify

Opened 5 months ago

Closed 5 months ago

Last modified 4 months ago

#22364 closed defect (duplicate)

NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.actions.SessionSaveAction

Reported by: OMNIBUS Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

Hi,
I just saw this false need for update screen opening my JOSM

These are the details:

`

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2022-08-29 16:59:00 +0200 (Mon, 29 Aug 2022)
Revision:18543
Build-Date:2022-08-30 01:30:57
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (18543 es) Linux Manjaro Linux
Memory Usage: 156 MB / 1912 MB (117 MB allocated, but free)
Java version: 11.0.16.1+1, Oracle Corporation, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: es_CO.utf8
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: es_CO
Numbers with default locale: 1234567890 -> 1234567890
Desktop environment: XFCE
VM arguments: [--add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, -Djosm.restart=true]

Last errors/warnings:
- 00000.945 E: Exception raised in EDT: java.util.concurrent.ExecutionException: java.lang.ExceptionInInitializerError. Causa: java.lang.ExceptionInInitializerError. Causa: java.lang.NullPointerException
- 00000.948 E: Exception raised in EDT: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.actions.SessionSaveAction. Causa: java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.actions.SessionSaveAction
- 00001.932 E: Handled by bug report queue: java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.actions.SessionSaveAction



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.actions.SessionSaveAction
	at org.openstreetmap.josm.gui.MainMenu.<init>(MainMenu.java:181)
	at org.openstreetmap.josm.gui.MainFrame.initialize(MainFrame.java:93)
	at org.openstreetmap.josm.gui.MainApplication.initializeMainWindow(MainApplication.java:415)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.runInitializationTasks(Lifecycle.java:103)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:71)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:953)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:277)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:741)

`

Attachments (0)

Change History (3)

comment:1 Changed 5 months ago by anonymous

Summary: False need update JOSMFalse need for update JOSM

comment:2 Changed 5 months ago by skyper

Keywords: update JOSM removed
Resolution: duplicate
Status: newclosed
Summary: False need for update JOSMNoClassDefFoundError: Could not initialize class org.openstreetmap.josm.actions.SessionSaveAction
Version: latesttested

Closed as duplicate of #22183.

comment:3 Changed 4 months ago by taylor.smock

In 18570/josm:

Fix #22183: NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.actions.SessionSaveAction

This was caused by JOSM detecting that it had started in IPv6 mode, but no IPv6
network was available. When this occurs, JOSM immediately sets a preference key
and restarts so that users are not confused about a lack of network connectivity.

The JOSM restart action then proceeds to attempt to save any active layers, but
since this occurs during startup, there are no active layers and the save actions
have not yet been initialized. The save actions cannot be initialized before
contentPanePrivate has been initialized, but the IPv6 call is done prior to
that happening, which may then trigger a JOSM restart, which calls exitJosm,
which then calls the save layers actions.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.