Modify

Opened 5 months ago

Closed 5 months ago

#22362 closed defect (duplicate)

Beim Start von JOSM

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start the application.

What is the expected result? Start the application.

What happens instead? Error. Application stopps.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2022-08-29 16:59:00 +0200 (Mon, 29 Aug 2022)
Build-Date:2022-08-30 01:30:57
Revision:18543
Relative:URL: ^/trunk

Identification: JOSM/1.5 (18543 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2009 (19043)
Memory Usage: 245 MB / 1820 MB (203 MB allocated, but free)
Java version: 1.8.0_341-b10, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 3840×2160 (scaling 1.00×1.00) \Display1 3840×2160 (scaling 1.00×1.00)
Maximum Screen Size: 3840×2160
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: de_DE
Numbers with default locale: 1234567890 -> 1234567890

Plugins:
+ RoadSigns
+ imagery_offset_db
+ turnrestrictions

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/BE.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1

Map paint styles:
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/DE.zip

Last errors/warnings:
- 00002.011 E: Exception raised in EDT: java.util.concurrent.ExecutionException: java.lang.ExceptionInInitializerError. Ursache: java.lang.ExceptionInInitializerError. Ursache: java.lang.NullPointerException
- 00012.928 E: Handled by bug report queue: java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.actions.SessionSaveAction



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.actions.SessionSaveAction
	at org.openstreetmap.josm.gui.MainMenu.<init>(MainMenu.java:181)
	at org.openstreetmap.josm.gui.MainFrame.initialize(MainFrame.java:93)
	at org.openstreetmap.josm.gui.MainApplication.initializeMainWindow(MainApplication.java:415)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.runInitializationTasks(Lifecycle.java:103)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:71)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:953)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:277)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:741)

Attachments (0)

Change History (1)

comment:1 Changed 5 months ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #22183.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.