Modify

Opened 2 years ago

Closed 2 years ago

#22202 closed defect (othersoftware)

Erronous Screen Artifacts in JOSM

Reported by: mrgenie Owned by: mrgenie
Priority: normal Milestone:
Component: Core Version:
Keywords: artifact Cc:

Description

Pictures say more than words - so I'm going to upload a few photos.

But the main thing is - and this can start to happen any time within 10s to 1 minute after starting JOSM - that the application itself seems to reproduce/copy buttons/windows/anything really and becomes completely unable to work with.

Note we tried to install the "web installer version"

or the "Self contained java" version

we also then copy-pasted a working version which works on another computer..

and have no idea what's causing it - my hunch would be this is a GPU driver issue - but I have no idea and I hope based on the photos someone can tell me what's the problem is.

Some general information:
windows OS
all drivers up to date
Nvidia
JOSM latest version as of July 7 2022 was the latest JOSM update
Java using version 8, 11, 17 tried several other java versions including the build-in..

all the same problem - which is why I think it's a GPU driver issue (but again, hope some professionals can tell me more)

Attachments (4)

WhatsApp Image 2022-07-09 at 2.15.38 PM.jpeg (129.9 KB ) - added by mrgenie 2 years ago.
WhatsApp Image 2022-07-09 at 2.15.39 PM (1).jpeg (153.6 KB ) - added by mrgenie 2 years ago.
WhatsApp Image 2022-07-09 at 2.15.39 PM.jpeg (110.5 KB ) - added by mrgenie 2 years ago.
WhatsApp Image 2022-07-09 at 2.16.31 PM.jpeg (70.5 KB ) - added by mrgenie 2 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 by skyper, 2 years ago

Similar to #21762. Maybe stoecker's comment 12 is helpful.

comment:2 by skyper, 2 years ago

Keywords: artifact added
Priority: majornormal

comment:3 by taylor.smock, 2 years ago

Owner: changed from team to mrgenie
Status: newneedinfo

@mrgenie: Let us know if any of the command line options work (the other reporter had some success with -Dsun.java2d.noddraw=true).

comment:4 by mrgenie, 2 years ago

After a lot of trial and error we discovered that running the app under windows in "compatibility" mode selecting "Win7" seems to solve the problem.

So right click
properties
go to compatibility tab
run in compatibility mode
select here windows 7

This can be closed and marked as solved.

Thanks

Last edited 2 years ago by mrgenie (previous) (diff)

comment:5 by taylor.smock, 2 years ago

Resolution: othersoftware
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain mrgenie.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.