Modify

Opened 11 years ago

Closed 10 years ago

#2172 closed defect (fixed)

[PATCH] ReverseWayTagCorrector's role correction is broken

Reported by: anonymous Owned by: framm
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Route members with role of forward/backward are sensitive to the direction of a way. So it would be nice to show a warning if the user wants to reverse such a way. This way it should be harder to mess up a route accidentally.

Attachments (1)

reversemember.patch (2.8 KB) - added by Teemu Koskinen <teemu.koskinen@…> 10 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by anonymous

Ticket #2629 has been marked as a duplicate of this ticket.

Changed 10 years ago by Teemu Koskinen <teemu.koskinen@…>

Attachment: reversemember.patch added

comment:2 Changed 10 years ago by Teemu Koskinen <teemu.koskinen@…>

Component: unspecifiedCore
Summary: warn on reversing ways which is a direction sensitive member[PATCH] ReverseWayTagCorrector's role correction is broken
Type: enhancementdefect
Version: latest

This is actually a bug, the ReverseWayTagCorrector gives the new version of the way to be checked with realEqual, which always fails because the reversed way's node list is in reverse order.

This patch adds the old way as a parameter for TagCorrector, and also changes the PrefixSuffixSwitcher to accept only the supplied prefix as-is (as route relations have only forward or backward as a role).

comment:3 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

In r1613.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.