Modify

Opened 6 months ago

Closed 2 weeks ago

#21619 closed defect (fixed)

[PATCH] CCE: josm.gui.widgets.JosmTextField cannot be cast to josm.gui.tagging.ac.AutoCompTextField (Exception on Map Projection)

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report projection Cc:

Description

What steps will reproduce the problem?

  1. Fresh install of JOSM via windows installer on Windows 10
  2. Loaded a map
  3. Went to Edit/Preferences to change map projection
  4. Selected Custom projection

What is the expected result?

Field appears to enter the projection

What happens instead?

Exception window appeared and field to add the projection did not appear.

Please provide any additional information below. Attach a screenshot if possible.

Revision:18303
Build-Date:2021-11-01 22:53:13

Identification: JOSM/1.5 (18303 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2009 (19043)
Memory Usage: 416 MB / 4082 MB (145 MB allocated, but free)
Java version: 17.0.1+12-LTS, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1600×900 (scaling 1.00×1.00) \Display1 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: en_US
Numbers with default locale: 1234567890 -> 1234567890
VM arguments: [-Djpackage.app-version=1.5.18303, --add-modules=java.scripting,java.sql,javafx.controls,javafx.media,javafx.swing,javafx.web, --add-exports=java.base/sun.security.action=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-opens=java.base/java.nio=ALL-UNNAMED, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, -Djpackage.app-path=%UserProfile%\AppData\Local\JOSM\JOSM.exe]
Dataset consistency test: No problems found

Last errors/warnings:
- 00000.684 W: extended font config - overriding 'filename.Myanmar_Text=mmrtext.ttf' with 'MMRTEXT.TTF'
- 00000.687 W: extended font config - overriding 'filename.Mongolian_Baiti=monbaiti.ttf' with 'MONBAITI.TTF'
- 00021.981 E: java.security.KeyStoreException: Windows-ROOT not found. Cause: java.security.NoSuchAlgorithmException: Windows-ROOT KeyStore not available
- 00111.194 E: Handled by bug report queue: java.lang.ClassCastException: class org.openstreetmap.josm.gui.widgets.JosmTextField cannot be cast to class org.openstreetmap.josm.gui.tagging.ac.AutoCompTextField (org.openstreetmap.josm.gui.widgets.JosmTextField and org.openstreetmap.josm.gui.tagging.ac.AutoCompTextField are in unnamed module of loader 'app')
- 00123.914 E: Handled by bug report queue: java.lang.ClassCastException: class org.openstreetmap.josm.gui.widgets.JosmTextField cannot be cast to class org.openstreetmap.josm.gui.tagging.ac.AutoCompTextField (org.openstreetmap.josm.gui.widgets.JosmTextField and org.openstreetmap.josm.gui.tagging.ac.AutoCompTextField are in unnamed module of loader 'app')



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (24) of main
java.lang.ClassCastException: class org.openstreetmap.josm.gui.widgets.JosmTextField cannot be cast to class org.openstreetmap.josm.gui.tagging.ac.AutoCompTextField (org.openstreetmap.josm.gui.widgets.JosmTextField and org.openstreetmap.josm.gui.tagging.ac.AutoCompTextField are in unnamed module of loader 'app')
	at org.openstreetmap.josm.gui.tagging.ac.AutoCompComboBox.getEditorComponent(AutoCompComboBox.java:85)
	at org.openstreetmap.josm.gui.tagging.ac.AutoCompComboBox.getEditorComponent(AutoCompComboBox.java:27)
	at org.openstreetmap.josm.gui.widgets.JosmComboBox.setText(JosmComboBox.java:192)
	at org.openstreetmap.josm.gui.preferences.projection.CustomProjectionChoice$PreferencePanel.build(CustomProjectionChoice.java:75)
	at org.openstreetmap.josm.gui.preferences.projection.CustomProjectionChoice$PreferencePanel.<init>(CustomProjectionChoice.java:59)
	at org.openstreetmap.josm.gui.preferences.projection.CustomProjectionChoice.getPreferencePanel(CustomProjectionChoice.java:214)
	at org.openstreetmap.josm.gui.preferences.projection.ProjectionPreference.selectedProjectionChanged(ProjectionPreference.java:521)
	at org.openstreetmap.josm.gui.preferences.projection.ProjectionPreference.lambda$setupProjectionCombo$5(ProjectionPreference.java:551)
	at java.desktop/javax.swing.JComboBox.fireActionEvent(Unknown Source)
	at java.desktop/javax.swing.JComboBox.setSelectedItem(Unknown Source)
	at java.desktop/javax.swing.JComboBox.setSelectedIndex(Unknown Source)
	at java.desktop/javax.swing.plaf.basic.BasicComboPopup$Handler.mouseReleased(Unknown Source)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.desktop/java.awt.Component.processMouseEvent(Unknown Source)
	at java.desktop/javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.desktop/javax.swing.plaf.basic.BasicComboPopup$1.processMouseEvent(Unknown Source)
	at java.desktop/java.awt.Component.processEvent(Unknown Source)
	at java.desktop/java.awt.Container.processEvent(Unknown Source)
	at java.desktop/java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Component.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Component.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.desktop/java.awt.EventQueue$5.run(Unknown Source)
	at java.desktop/java.awt.EventQueue$5.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.desktop/java.awt.WaitDispatchSupport$2.run(Unknown Source)
	at java.desktop/java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.desktop/java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.desktop/java.awt.WaitDispatchSupport.enter(Unknown Source)
	at java.desktop/java.awt.Dialog.show(Unknown Source)
	at java.desktop/java.awt.Component.show(Unknown Source)
	at java.desktop/java.awt.Component.setVisible(Unknown Source)
	at java.desktop/java.awt.Window.setVisible(Unknown Source)
	at java.desktop/java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.setVisible(PreferenceDialog.java:145)
	at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:119)
	at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:104)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at java.desktop/javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at java.desktop/javax.swing.AbstractButton.doClick(Unknown Source)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.desktop/java.awt.Component.processMouseEvent(Unknown Source)
	at java.desktop/javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.desktop/java.awt.Component.processEvent(Unknown Source)
	at java.desktop/java.awt.Container.processEvent(Unknown Source)
	at java.desktop/java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Component.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Component.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.desktop/java.awt.EventQueue$5.run(Unknown Source)
	at java.desktop/java.awt.EventQueue$5.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.run(Unknown Source)

Attachments (2)

21619.patch (3.2 KB) - added by marcello@… 6 months ago.
patch
21619.2.patch (1.7 KB) - added by taylor.smock 6 months ago.
Minimal patch (no non-regression test)

Download all attachments as: .zip

Change History (13)

comment:1 Changed 6 months ago by skyper

Ticket #21622 has been marked as a duplicate of this ticket.

comment:2 Changed 6 months ago by skyper

Keywords: projection added
Summary: Exception on Map ProjectionCCE: josm.gui.widgets.JosmTextField cannot be cast to josm.gui.tagging.ac.AutoCompTextField (Exception on Map Projection)
Version: tested

Changed 6 months ago by marcello@…

Attachment: 21619.patch added

patch

comment:3 Changed 6 months ago by marcello@…

Summary: CCE: josm.gui.widgets.JosmTextField cannot be cast to josm.gui.tagging.ac.AutoCompTextField (Exception on Map Projection)[PATCH] CCE: josm.gui.widgets.JosmTextField cannot be cast to josm.gui.tagging.ac.AutoCompTextField (Exception on Map Projection)

Changed 6 months ago by taylor.smock

Attachment: 21619.2.patch added

Minimal patch (no non-regression test)

comment:4 in reply to:  3 Changed 6 months ago by taylor.smock

Replying to marcello@…:
Marcello's patch is probably better. I don't know about removing the input field (plugins may depend upon it). If we do remove that field, I'd feel more comfortable doing it after this month's release.

comment:5 Changed 6 months ago by marcello@…

only the opendata plugin calls getPreferencePanel() and does not use input.

comment:6 Changed 4 months ago by GerdP

Ticket #21790 has been marked as a duplicate of this ticket.

comment:7 Changed 4 months ago by GerdP

What's the status?

comment:8 Changed 4 months ago by taylor.smock

Good question. I don't think the patch has ever been applied.

Like I said in comment:4, I think marcello's patch is better.

comment:9 Changed 4 months ago by skyper

Another duplicate #21790

comment:10 Changed 4 months ago by taylor.smock

@marcello's patch still applies cleanly.

comment:11 Changed 2 weeks ago by taylor.smock

Resolution: fixed
Status: newclosed

In 18438/josm:

Fix #21619: CCE where JosmTextField cannot be cast to AutoCompTextField (patch by marcello, modified)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.