Modify

Opened 9 months ago

Last modified 9 months ago

#21579 new defect

two easypreset plugins in the Preferences dialog

Reported by: leni Owned by: GerdP
Priority: normal Milestone:
Component: Plugin Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. in the Preferences dialog, I search "easypreset"

What is the expected result?

Find the EasyPreset plugin.

What happens instead?

I find 2 plugins that look the same and point to the same url

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-11-01 23:05:46 +0100 (Mon, 01 Nov 2021)
Build-Date:2021-11-01 22:25:18
Revision:18303
Relative:URL: ^/trunk

Identification: JOSM/1.5 (18303 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2009 (19042)
Memory Usage: 596 MB / 910 MB (172 MB allocated, but free)
Java version: 1.8.0_311-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.formdev.flatlaf.FlatLightLaf
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: en_FR
Numbers with default locale: 1234567890 -> 1234567890

Plugins:
+ Mapillary (2.0.0-alpha.41)
+ PicLayer (1.0.1)
+ apache-commons (35524)
+ apache-http (35589)
+ contourmerge (v0.1.8)
+ ejml (35458)
+ flatlaf (35799)
+ geotools (35458)
+ imagery_offset_db (35640)
+ indoorhelper (1.2.0)
+ jaxb (35543)
+ jna (35662)
+ jts (35458)
+ measurement (35640)
+ openqa (0.2.2)
+ photo_geotagging (35783)
+ photoadjust (35770)
+ scripting (30798)
+ shrinkwrap (v1.0.4)
+ tageditor (35640)
+ turnrestrictions (35640)
+ undelete (35848)
+ utilsplugin2 (35856)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://github.com/Jungle-Bus/josm-presets/raw/gh-pages/jungle-stops/preset.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
+ <josm.pref>\styles\sit.mapcss
+ <josm.pref>\styles\sit.mapcss
- <josm.pref>\styles\sit.mapcss

Validator rules:
+ https://raw.githubusercontent.com/nlehuby/transport_mapcss/master/transport.validator.mapcss

Attachments (2)

EasyPreset.png (24.6 KB) - added by leni 9 months ago.
EasyPresets.jar (135.4 KB) - added by leni 9 months ago.

Download all attachments as: .zip

Change History (13)

Changed 9 months ago by leni

Attachment: EasyPreset.png added

comment:1 Changed 9 months ago by GerdP

Cannot reproduce this. Maybe your local copy of the plugin list is wrong. Please click on the "Download list" button in the preferences dialog first.

comment:2 Changed 9 months ago by leni

I clicked on the "Download list" button and it is the same.
I installed the latest version of josm and plugins on another computer and I have the same behaviour.
Both computers are running w10

I rename my preferences.xml : unchanged

Last edited 9 months ago by leni (previous) (diff)

comment:3 Changed 9 months ago by skyper

Hi Leni
Yet, again, this looks like a problem of updating plugins and/or the cached plugin version. Renaming preferences.xml does not help, cause the files are cached/downloaded in another directory, see Help/Preferences#JOSMpreferencedatacachedirectories.

I still do not get why you have such big problems with updating plugins and wonder if it is a problem of Windows together with java 8?

comment:4 Changed 9 months ago by GerdP

I think the plugin list is in the plugin directory: site-josm.openstreetmap.de-_pluginicons.txt
I also use Windows + java 8 and don't see this problem.

Make sure that this file is not write protected.

Last edited 9 months ago by GerdP (previous) (diff)

comment:5 in reply to:  4 Changed 9 months ago by leni

Replying to GerdP:

I think the plugin list is in the plugin directory: site-josm.openstreetmap.de-_pluginicons.txt
Make sure that this file is not write protected.

Thanks.
The file was not write-protected.

But in the %APPDATA%\JOSM\plugins folder, I found the file "EasyPresets.jar" which I moved and I no longer have the double display. I only have "easypresets"

Last edited 9 months ago by leni (previous) (diff)

comment:6 Changed 9 months ago by leni

Resolution: fixed
Status: newclosed

comment:7 Changed 9 months ago by skyper

Strange, this reminds me of #19006.

comment:8 in reply to:  7 Changed 9 months ago by leni

Replying to skyper:

Strange, this reminds me of #19006.

It looks like, indeed, JOSM is looking in both places, since there are both displays (the version is the same but one with "local: numVersion" and the other "local: unknown" - the "EasyPresets.jar" file was capitalized, created on March 22, 2021, modified on July 4, 2021)

Perhaps the #19006 should be re-opened? and indicate this one as a duplicate?

comment:9 Changed 9 months ago by GerdP

Please attach the old plugin here. I'll try to reproduce.

Changed 9 months ago by leni

Attachment: EasyPresets.jar added

comment:10 Changed 9 months ago by GerdP

Resolution: fixed
Status: closedreopened

OK, I can reproduce your results. Problem disappears when you rename the jar to easypresets.jar (all lower-case). Probably a Windows speciality.

comment:11 Changed 9 months ago by GerdP

Owner: changed from team to GerdP
Status: reopenednew

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain GerdP.
as The resolution will be set.
to The owner will be changed from GerdP to the specified user.
The owner will change to leni
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from GerdP to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.