Modify

Opened 6 months ago

Last modified 6 months ago

#21092 new enhancement

public_transport=platform not showing proper icon in the relation window but ONLY for ways and polygons

Reported by: mrgenie Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: public_transport highway platform icon way Cc:

Description (last modified by Klumbumbus)

Example:
https://wiki.openstreetmap.org/wiki/Public_transport#Buses

On the left side you can add a single node and add:

public_transport=platform
name=location stop
bus=yes/no/....

so in the window that says:"Tags: 3 / Memberships: 0" the icon for Transport/Public Transport/platform is shown properly.

In the window that says:"Sel.: Rel.:0 / Ways:0 / Nodes:1"
this node is shown if selected with the proper icon

In the window "Create new relation in layer 'Data Layer 1'"
you can now add this node and it will be added as role platform and show the right icon of the platform.

works great!

Now here comes this problem:
On the right side in https://wiki.openstreetmap.org/wiki/Public_transport#Buses
you can also select a platform as a way or area that's described on the right side of buses
as highway=platform (and yes I also tried public_transport=platform)
the thing is the moment it's not a single node but a way/area then this is the result

Tags: 3 / Memberships: 1 window shows the icon properly for both highway=platform and public_transport=platform

and here it comes:
Sel.: Rel.:0 / Ways: 1 / Nodes:0
does NOT show the icon .. it shows either the icon for way or area but NOT the icon for platform!!!

and analog the window "Edit new relation in layer 'Data Layer 1'"
also does show just a way or polygon icon but NOT the actual icon for platform for either
highway or public_transport.

This is very confusing for the user - as it might suggest somewhere we tagged something wrong.
But it's not tagged wrong - as the first window where you actually set the keys/values shows the right icons for NODE and WAY and AREA

It's just the windows "Sel.: Rel.: 0 / Ways:1 / Nodes:0" and "relations" don't show the right icons

Screenshots:

The icons as they should be (even if tagging is wrong or not according to OSM-wiki - at least the icons should be consistent!):

This file shows the icons as they should be (even if tagging is wrong or not according to OSM-wiki - at least the icons should be consistent!!!!)

This shows the wrong icons - the moment these keys/values are set to a way:

This shows the wrong icons - the moment these keys/values are set to a way

This shows the wrong icons - also for a node since highway tag can't be set to a node? Either way, as said earlier the icon should be right for "highway=platform" regardless if it's for a node or way or area:

This shows the wrong icons - also for a node since highway tag can't be set to a node? Either way, as said earlier the icon should be right for "highway=platform" regardless if it's for a node or way or area

This shows the wrong icons - the moment these keys/values are set to a way:

This shows the wrong icons - the moment these keys/values are set to a way

Attachments (4)

public_transport=platform_node_correct_icon.png (548.3 KB) - added by mrgenie 6 months ago.
This file shows the icons as they should be (even if tagging is wrong or not according to OSM-wiki - at least the icons should be consistent!!!!)
public_transport=platform_way_wrong_icon.png (551.3 KB) - added by mrgenie 6 months ago.
This shows the wrong icons - the moment these keys/values are set to a way
highway=platform_way_wrong_icon.png (539.0 KB) - added by mrgenie 6 months ago.
This shows the wrong icons - the moment these keys/values are set to a way
highway=platform_node_wrong_icon.png (571.5 KB) - added by mrgenie 6 months ago.
This shows the wrong icons - also for a node since highway tag can't be set to a node? Either way, as said earlier the icon should be right for "highway=platform" regardless if it's for a node or way or area

Change History (9)

Changed 6 months ago by mrgenie

This file shows the icons as they should be (even if tagging is wrong or not according to OSM-wiki - at least the icons should be consistent!!!!)

Changed 6 months ago by mrgenie

This shows the wrong icons - the moment these keys/values are set to a way

Changed 6 months ago by mrgenie

This shows the wrong icons - the moment these keys/values are set to a way

Changed 6 months ago by mrgenie

This shows the wrong icons - also for a node since highway tag can't be set to a node? Either way, as said earlier the icon should be right for "highway=platform" regardless if it's for a node or way or area

comment:1 Changed 6 months ago by mrgenie

Description: modified (diff)

comment:2 Changed 6 months ago by Don-vip

Description: modified (diff)

comment:3 Changed 6 months ago by Klumbumbus

The 2nd and the 4th screenshot show the same problem, don't they? (just different tags)

comment:4 Changed 6 months ago by Klumbumbus

Description: modified (diff)

comment:5 Changed 6 months ago by skyper

Keywords: way added; window removed
Type: defectenhancement

The icon in the preset links is using the icon from the preset.
All other icons use the the icon from the section list panel which are only changed for nodes and (some) relations but not for ways.

highway=platform was approved to be only valid on ways and areas, so the wiki page should reflect this. Additionally highway and railway have a higher position in key hierarchy than public_transport causing the invalid tag icon to be displayed.

I see room for improvements:

  1. Removing type=node from highway/railway=platform presets
  2. Use distinct icons for ways in selection list panel but do not loose the information about the object type (node or way)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to mrgenie
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from team to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.