Modify

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#21048 closed defect (fixed)

Validation issue when adding a multipolygon to building relation

Reported by: hubaishan Owned by: team
Priority: normal Milestone: 21.06
Component: Internal preset Version: tested
Keywords: validator building relation member role Cc:

Description

Validation issue when I add a mutipolygon relation to "building" relation as "part"
role "part" in building relation must accept any area : closed ways or multipolygon relations

Attachments (0)

Change History (8)

comment:1 Changed 12 months ago by hubaishan

Summary: Validation issuse when adding a mutipolygon to building relationValidation issue when adding a mutipolygon to building relation

comment:2 Changed 12 months ago by skyper

Component: Core validatorInternal preset
Keywords: validator building relation member role added

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.


comment:3 Changed 12 months ago by skyper

Owner: changed from team to hubaishan
Status: newneedinfo

comment:4 Changed 12 months ago by Klumbumbus

Milestone: 21.06
Owner: changed from hubaishan to team
Status: needinfonew

also the preset uses the deprecated roles entrance and level_n
https://wiki.openstreetmap.org/wiki/Relation:building

comment:5 Changed 12 months ago by Klumbumbus

Summary: Validation issue when adding a mutipolygon to building relationValidation issue when adding a multipolygon to building relation

comment:6 Changed 12 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 17943/josm:

fix #21048 - Allow multipolygons as inner part of building relations with role part; remove the roles entrance and level_n (deprecated tagging schema), this automatically adds warnings for both roles ("...is not among expected values...")

comment:7 Changed 12 months ago by Klumbumbus

In 17945/josm:

see #21048 - Fix unit test

comment:8 Changed 12 months ago by Klumbumbus

In 17946/josm:

see #21048 - Fix unit test again

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.