Modify

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#21045 closed defect (duplicate)

Not enough memory to show imagery

Reported by: j.moserfranscini@… Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Imagerie -> Images mondiales ESRI

What is the expected result?

See imagery

What happens instead?

Instead of imagery, black background with message "Not enough memory to draw layer: images mondiales ESRI"

Please provide any additional information below. Attach a screenshot if possible.

-Issue not limited to this specific imagery. Also happens with other imagery, such as e.g. OpenStreetMap

-Imagery is still showing properly with previous version 15628.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-06-02 22:03:39 +0200 (Wed, 02 Jun 2021)
Build-Date:2021-06-02 20:11:30
Revision:17919
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17919 fr) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 2004 (19041)
Memory Usage: 185 MB / 247 MB (77 MB allocated, but free)
Java version: 1.8.0_291-b10, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 3840×2160 (scaling 1.00×1.00)
Maximum Screen Size: 3840×2160
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: fr_CH
Numbers with default locale: 1234567890 -> 1234567890

Plugins:
+ imagery_offset_db (35640)
+ reverter (35732)
+ turnrestrictions (35640)

Attachments (1)

Capture d’écran 2021-06-27 082046.jpg (58.7 KB) - added by j.moserfranscini@… 4 months ago.

Download all attachments as: .zip

Change History (7)

Changed 4 months ago by j.moserfranscini@…

comment:1 in reply to:  description Changed 4 months ago by skyper

Replying to j.moserfranscini@…:

Memory Usage: 185 MB / 247 MB (77 MB allocated, but free)

This is quite few memory for JOSM. You should give java more memory (-Xmx).
Note since a few month JOSM needs more memory for imagery.

comment:2 Changed 4 months ago by skyper

Component: CoreCore imagery
Resolution: duplicate
Status: newclosed

Closed as duplicate of #20666.

comment:3 Changed 4 months ago by j.moserfranscini@…

I don't know how/where one gives more memory to java, but in any case I re-installed ver 17919 and now imagery works.
Thank you for your help.

comment:4 Changed 4 months ago by skyper

How do you install JOSM, josm.jnlp, josm.jar or Windows installer package?
For memory settings see Help/CommandLineOptions and Download. Hope that is helpful.

comment:5 Changed 4 months ago by jam9264

This time I have used the windows installer (and it works).
Previously I have simply double-clicked josm-tested.jar (it worked for ver 15628, not for 17919). And I *believe* (not sure) that my first attempt with 17919 (which did not work) was "start josm.jnlp".

comment:6 Changed 4 months ago by GerdP

I suggest to install the 64 bit version of Java.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.