Modify

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#20946 closed defect (fixed)

MacOS build not done

Reported by: stoecker Owned by: simon04
Priority: normal Milestone: 21.05
Component: Installer MacOS Version:
Keywords: Cc: Don-vip

Description (last modified by stoecker)

Release 17915 was started and also exists:
https://github.com/openstreetmap/josm/releases/tag/17915-tested
but there is no MacOS-exe included.

See #20146.

Attachments (0)

Change History (13)

comment:1 Changed 6 months ago by stoecker

Description: modified (diff)
Summary: MacOS build not done (see #20146)MacOS build not done

comment:2 Changed 6 months ago by simon04

Regression of r17905?

compile:
    [javac] Compiling 1692 source files to /Users/runner/work/josm/josm/build
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 8
    [javac] 1 warning
    [javac] Exception in thread "main" com.google.errorprone.InvalidCommandLineOptionException: InlineMeSuggester is not a valid checker name
    [javac] 	at com.google.errorprone.scanner.ScannerSupplier.lambda$applyOverrides$8(ScannerSupplier.java:186)
    [javac] 	at com.google.common.collect.RegularImmutableMap.forEach(RegularImmutableMap.java:185)
    [javac] 	at com.google.errorprone.scanner.ScannerSupplier.applyOverrides(ScannerSupplier.java:179)

BUILD FAILED
/Users/runner/work/josm/josm/build.xml:217: Compile failed; see the compiler error output for details.

But why? We're using errorprone 2.7.1 since r17893, and support for InlineMe has been added in 2.7.0, see https://github.com/google/error-prone/releases/tag/v2.7.0

There's something fishy with not catching up the JavaCC update to 7.0.10 from r17907 in the build of r17915: https://github.com/openstreetmap/josm/runs/2712999905?check_suite_focus=true#step:8:33

What's going on? Is this some caching issue on GitHub Actions?

comment:3 Changed 6 months ago by simon04

In 17918/josm:

see #20946 - GitHub Actions: hash also build.xml and tools/ivy.xml for cache key

comment:4 in reply to:  3 Changed 6 months ago by Don-vip

Replying to simon04:

In 17918/josm:

see #20946 - GitHub Actions: hash also build.xml and tools/ivy.xml for cache key

ah, good catch

comment:5 Changed 6 months ago by simon04

🥳 Yesss! Every build is 🟢 again: https://github.com/openstreetmap/josm/actions/runs/900489662

Do we need to bump the tested version (aka. hotfix) for a proper macOS release, now?

comment:6 Changed 6 months ago by simon04

Owner: changed from Stereo to simon04
Status: assignednew

comment:7 in reply to:  5 Changed 6 months ago by Don-vip

Replying to simon04:

Do we need to bump the tested version (aka. hotfix) for a proper macOS release, now?

Probably the simplest way to go.

comment:8 Changed 6 months ago by Don-vip

Wait a few minutes, I need to trigger the build first.

comment:9 Changed 6 months ago by simon04

Ideally we'd include r17919 (a critical bug fix).

comment:10 Changed 6 months ago by Don-vip

okay, r17919 is the new latest now. Go ahead if you want to promote it as hotfix.

comment:11 Changed 6 months ago by simon04

comment:12 Changed 6 months ago by simon04

Milestone: 21.05
Resolution: fixed
Status: newclosed

comment:13 Changed 6 months ago by simon04

Yay, the GitHub release contains the macOS packages: https://github.com/openstreetmap/josm/releases/tag/17919-tested

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.