Modify

Opened 13 months ago

Closed 12 months ago

Last modified 12 months ago

#20924 closed defect (fixed)

[patch] leisure=dog_park preset suggests to add area; validator complains about area

Reported by: Famlam Owned by: team
Priority: normal Milestone: 21.06
Component: Internal preset Version: tested
Keywords: template_report dog_park area Cc:

Description

What steps will reproduce the problem?

  1. Add a leisure=dog_park area using the corresponding preset
  2. Tick area in the preset dialog box
  3. Run the validator

What is the expected result?

As the validator states area is unnecessary, the preset shouldn't suggest it

What happens instead?

Validator warning about unnecessary tag area + preset offering area

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-04-27 20:35:33 +0200 (Tue, 27 Apr 2021)
Build-Date:2021-04-27 21:58:39
Revision:17833
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17833 nl) Windows 10 64-Bit
OS Build number: Windows 10 Home 2009 (19042)
Memory Usage: 1006 MB / 1820 MB (306 MB allocated, but free)
Java version: 1.8.0_291-b10, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: nl_NL
Numbers with default locale: 1234567890 -> 1234567890
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35640)
+ SimplifyArea (35640)
+ imagery_offset_db (35640)
+ pt_assistant (2.1.10-80-g7d9bba3)
+ reverter (35732)
+ tageditor (35640)
+ turnlanes-tagging (288)
+ undelete (35640)
+ utilsplugin2 (35691)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ %UserProfile%\Documents\tijdelijke bestanden\josm-eigen.mappaint.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1

Validator rules:
+ %UserProfile%\Documents\tijdelijke bestanden\josm-eigen.validator.mapcss

Attachments (2)

josm_20924.patch (568 bytes) - added by skyper 13 months ago.
patch only removing area=yes
josm_20924_no_barrier.patch (603 bytes) - added by skyper 13 months ago.
patch removing barrier=* in addition

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 months ago by skyper

Owner: changed from team to skyper

Changed 13 months ago by skyper

Attachment: josm_20924.patch added

patch only removing area=yes

Changed 13 months ago by skyper

Attachment: josm_20924_no_barrier.patch added

patch removing barrier=* in addition

comment:2 Changed 13 months ago by skyper

Owner: changed from skyper to team
Summary: leisure=dog_park preset suggests to add area; validator complains about area[patch] leisure=dog_park preset suggests to add area; validator complains about area

I have attached two different patch files:

Last edited 13 months ago by skyper (previous) (diff)

comment:3 Changed 13 months ago by Famlam

barrier=* is part of that wiki page from the moment it left the proposal stage, so I guess it could stay in for now?
(I think fenced was removed as you'd then also need to invent walled etc; besides having two tags for the same purpose)

Obviously, the barrier would be better drawn as a separate way, unless you have to throw your dog over the fence to get it in, but since the nodes would overlap - and a fence cannot be an area - I understand that it's convenient to combine them ;)

comment:4 Changed 13 months ago by skyper

Exactly, there are better ways and the current situations contradicts "one object one feature" and should not be offered. Usually, the fence is not directly on the border of the park but close to it.

In my eyes, fenced=yes is not a "barrier", in first place, but a property of an area and not identical with barrier=fence.

Last edited 13 months ago by skyper (previous) (diff)

comment:5 Changed 13 months ago by Famlam

I'm fine with removing it too; it's a preset, not a validator rule, so those that prefer it, can still add it manually :)

comment:6 Changed 12 months ago by skyper

Milestone: 21.06

Ping

comment:7 Changed 12 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 17922/josm:

fix #20924 - Remove area=yes and barrier=* from leisure=dog_park preset (patch by skyper)

comment:8 Changed 12 months ago by Klumbumbus

Milestone: 21.0621.05

comment:9 Changed 12 months ago by Klumbumbus

Milestone: 21.0521.06

comment:10 Changed 12 months ago by skyper

Thanks

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.