Modify

Opened 13 months ago

Closed 12 months ago

Last modified 12 months ago

#20922 closed defect (fixed)

"Unknown property value" should consider value separator as major difference or exclude "*:lanes[.*]" tags from this test

Reported by: anonymous Owned by: team
Priority: normal Milestone: 21.06
Component: Core validator Version: latest
Keywords: lanes property value Cc:

Description

In the validator the tagging of a 4 lanes way with hgv:lanes=no|yes|yes|yes are detectet as wrong and giving me hgv:lanes=|no|yes|yes|yes as solution wit one more | at the beginnig.

Attachments (0)

Change History (15)

comment:1 Changed 13 months ago by skyper

Owner: changed from team to anonymous
Status: newneedinfo

Cannot reproduce with r17903. Do not remember any test to suggest adding or removing values from *:lanes tags.


Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.


comment:2 Changed 13 months ago by anonymous

I use r17903 on Win10:

Plugins:
+ CustomizePublicTransportStop (35760)
+ OpeningHoursEditor (35640)
+ PicLayer (2a9aa7a)
+ apache-commons (35524)
+ areaselector (368)
+ austriaaddresshelper (1597341117)
+ continuosDownload (91)
+ contourmerge (v0.1.8)
+ ejml (35458)
+ geotools (35458)
+ jaxb (35543)
+ jts (35458)
+ log4j (35458)
+ opendata (35640)
+ public_transport (35640)
+ reverter (35732)
+ tageditor (35640)
+ terracer (35640)
+ turnlanes (35640)
+ turnlanes-tagging (288)
+ turnrestrictions (35640)
+ undelete (35640)
+ utilsplugin2 (35691)
+ waydownloader (35640)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Incline&zip=1

Tested again with some of the following ways by klicking on "Validate" in my sidebar:
https://www.openstreetmap.org/way/552067122 hgv:lanes
https://www.openstreetmap.org/way/331530958 hgv:lanes and bus:lanes
https://www.openstreetmap.org/way/683647786 hgv:lanes

Same value in all *:lanes
https://i.ibb.co/4fWjF51/lanes.png

comment:3 Changed 13 months ago by anonymous

Owner: changed from anonymous to team
Status: needinfonew

comment:4 Changed 13 months ago by simon04

Your status report is incomplete (lacks the first block of information)!

I cannot reproduce: Validating https://www.openstreetmap.org/way/552067122 does not yield any warnings/errors. Is any of your plugins causing the warning? Please copy the warning message!

Revision:17908
Is-Local-Build:true
Build-Date:2021-05-23 22:29:14

Identification: JOSM/1.5 (17908 SVN en) Mac OS X 11.3.1
OS Build number: macOS 11.3.1 (20E241)
Memory Usage: 420 MB / 2048 MB (206 MB allocated, but free)
Java version: 16.0.1+9, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.formdev.flatlaf.FlatLightLaf
Screen: Display 1 1440×900 (scaling 2.00×2.00) Display 2 3008×1692 (scaling 2.00×2.00)
Maximum Screen Size: 3008×1692
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: en_IE.UTF-8
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: en_AT
Numbers with default locale: 1234567890 -> 1234567890
VM arguments: [-agentlib:jdwp=transport=dt_socket,address=127.0.0.1:53452,suspend=y,server=n, --add-exports=java.desktop/com.apple.eawt=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-opens=java.base/java.nio=ALL-UNNAMED, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, -Djosm.dir.name=JOSM.dev, -javaagent:/Users/simon/Library/Caches/JetBrains/IntelliJIdea2021.1/captureAgent/debugger-agent.jar, -Dfile.encoding=UTF-8]
Program arguments: [--language, en, --set, tls.add-missing-certificates=false]
Dataset consistency test: No problems found

Plugins:
+ flatlaf (35734)
+ pbf (35720)
+ wikipedia (1.1.4)

comment:5 Changed 13 months ago by simon04

Owner: changed from team to anonymous
Status: newneedinfo

comment:6 Changed 13 months ago by anonymous

Component: Core validatorExternal preset
Owner: changed from anonymous to skyper
Status: needinfonew

it is a error in the https://josm.openstreetmap.de/wiki/Presets/LaneAttributes code

If you search for "|no|yes|yes|yes" you will find 27 errors in this preset

comment:7 Changed 13 months ago by skyper

Component: External presetCore validator
Keywords: lanes property value added; hgv:lanes removed
Owner: changed from skyper to team
Summary: hgv:lanes=no|yes|yes|yes detectet as wrong"Unknown property value" should consider value separator as major difference or "*:lanes[.*]" tags be excluded from this test

Empty "single" values are valid for *:lanes[:*] but it makes no sense for access keys. I removed the leading | (diff) but the problem is in validator which should probably exclude *:lanes[:*] from the Unknown property value test or at least consider the value separator | as major difference.

comment:8 Changed 13 months ago by skyper

Summary: "Unknown property value" should consider value separator as major difference or "*:lanes[.*]" tags be excluded from this test"Unknown property value" should consider value separator as major difference or exclude "*:lanes[.*]" tags from this test

comment:9 Changed 13 months ago by skyper

What steps will reproduce the problem?

  1. Have a preset with some values for a *:lanes[:*] tag, e.g. maxspeed:lanes with values |80|60,110|80
  2. Have a highway with maxspeed:lanes=80|60
  3. Run validator

What is the expected result?

No warning

What happens instead?

Warning: Unknown property value: Value '80|60' for key 'maxspeed:lanes' is unknown, maybe '|80|60' is meant?

comment:10 Changed 12 months ago by Klumbumbus

In 17924/josm:

see #20922 - Avoid false positive validator warnings like "Value x for key y is unknown, maybe z is meant?" regarding *:lanes, *:lanes:forward and *:lanes:backward tags

comment:11 in reply to:  9 Changed 12 months ago by Klumbumbus

skyper could you please double check? I think r17924 should be enough to fix this ticket?

Replying to skyper:

What happens instead?

Warning: Unknown property value: Value '80|60' for key 'maxspeed:lanes' is unknown, maybe '|80|60' is meant?

Hm, maxspeed:lanes=80|60 should not have produced this warning also before r17924, because maxspeed:lanes was in ignoretags.cfg

comment:12 Changed 12 months ago by skyper

Sorry, cannot reproduce either. Maybe I messed up with a local ignoretags.cfg or I did originally get this warning with width:lanes.

r17924 is probably enough but F::both_ways might be added, as well.

comment:13 Changed 12 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 17928/josm:

fix #20922 - Avoid false positive validator warnings like "Value x for key y is unknown, maybe z is meant?" regarding *:both_ways tags

comment:14 Changed 12 months ago by Klumbumbus

Thanks, skyper!

comment:15 Changed 12 months ago by Klumbumbus

Milestone: 21.06

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.