Modify

#20694 closed defect (fixed)

The error occurred while deleting a route layer with a .gpx extension created by the mapper

Reported by: anonymous Owned by: simon04
Priority: normal Milestone: 21.05
Component: Core Version:
Keywords: template_report gpx save delete Cc:

Description

What steps will reproduce the problem?

  1. The error occurred while deleting a route layer with a .gpx extension created by the mapper

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-03-17 18:58:40 +0100 (Wed, 17 Mar 2021)
Build-Date:2021-03-17 17:59:56
Revision:17580
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17580 pt_BR) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 247 MB / 247 MB (9 MB allocated, but free)
Java version: 1.8.0_181-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1366×768 (scaling 1,00×1,00) \Display1 1360×768 (scaling 1,00×1,00)
Maximum Screen Size: 1366×768
Best cursor sizes: 16×16→32×32, 32×32→32×32

Plugins:
+ CADTools (1008)
+ FastDraw (35640)
+ apache-commons (35524)
+ apache-http (35589)
+ buildings_tools (35669)
+ javafx-windows (35655)
+ jna (35662)

Map paint styles:
+ %UserProfile%\Downloads\Kaart-Styles.mapcss

Validator rules:
+ %UserProfile%\Documents\Open Street Maps\Josm\kaart.validator.mapcss

Last errors/warnings:
- 05982,275 E: java.lang.reflect.InvocationTargetException. Causa: java.util.regex.PatternSyntaxException: Illegal character range near index 6
- 06093,005 E: Error header: The changeset 101985468 was closed at 2021-03-30 12:26:20 UTC
- 06100,313 E: Error header: Version mismatch: Provided 52, server had: 54 of Way 31577733
- 06100,992 E: Conflitos detectados - <html>Envio <strong>falhou</strong> porque o servidor tem uma nova versão de um<br>de seus nós, caminhos ou relações.<br>Este conflito é causado pelo(a) <strong>caminho</strong> com id <strong>31.577.733</strong>.<br>O servidor tem a versão 54, e sua versão é 52.<br><br>Clique <strong>Sincronizar apenas o caminho 31.577.733</strong> para sincronizar somente a primitiva conflitante.<br>Clique <strong>Sincronizar todo o conjunto de dados</strong> para sincronizar todo o conjunto de dados locais no servidor<br>Clique <strong>Cancelar</strong> para abortar e continuar editando.<br></html>
- 06127,978 W: Conflitos detectados - <html>Houve 1 conflito detectado.</html>
- 06185,917 E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- 06185,920 E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- 06275,629 E: java.lang.reflect.InvocationTargetException. Causa: java.util.regex.PatternSyntaxException: Illegal character range near index 6
- 06282,323 E: java.lang.reflect.InvocationTargetException. Causa: java.util.regex.PatternSyntaxException: Illegal character range near index 6
- 06616,380 E: Handled by bug report queue: java.lang.NullPointerException



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (16) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.layer.GpxLayer.isModified(GpxLayer.java:559)
	at org.openstreetmap.josm.gui.layer.GpxRouteLayer.isModified(GpxRouteLayer.java:43)
	at org.openstreetmap.josm.gui.io.SaveLayersDialog.saveUnsavedModifications(SaveLayersDialog.java:119)
	at org.openstreetmap.josm.gui.dialogs.layer.DeleteLayerAction.actionPerformed(DeleteLayerAction.java:46)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 in reply to:  description Changed 14 months ago by skyper

Keywords: gpx save delete added

Replying to anonymous:

Memory Usage: 247 MB / 247 MB (9 MB allocated, but free)
Java version: 1.8.0_181-b13, Oracle Corporation, Java HotSpot(TM) Client VM

Looks like a problem of too less memory. How do you start JOSM?

Additionally, your java version is quite old and needs an update.

comment:2 Changed 12 months ago by skyper

Ticket #20889 has been marked as a duplicate of this ticket.

comment:3 Changed 12 months ago by simon04

Milestone: 21.05
Owner: changed from team to simon04
Status: newassigned

comment:4 Changed 12 months ago by simon04

Resolution: fixed
Status: assignedclosed

In 17900/josm:

fix #20694 - NPE in GpxLayer.isModified

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.