Modify

Opened 3 years ago

Closed 3 years ago

#20656 closed defect (duplicate)

CSS :selected pseudoclass doesn't update for child items with selection change

Reported by: sinus+j@… Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version:
Keywords: css selected pseudoclass Cc:

Description (last modified by skyper)

Consider the following MapCSS rule:

way:selected > node { symbol-stroke-color:#ff00ff; }

It should color nodes of a selected way in pink. And it does, but the effect isn't applied with every selection change. Only more significant redraws or CSS reloads update the upstream :selected state.

Attachments (0)

Change History (5)

comment:1 by skyper, 3 years ago

Description: modified (diff)

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.


comment:2 by anonymous, 3 years ago

Very well, resubmitted from JOSM.

comment:3 by anonymous, 3 years ago

Resolution: duplicate
Status: newclosed

comment:4 by skyper, 3 years ago

Resolution: duplicate
Status: closedreopened

comment:5 by skyper, 3 years ago

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #20657.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.