Modify

#20647 closed enhancement (fixed)

Add --status-report command line argument

Reported by: simon04 Owned by: simon04
Priority: normal Milestone: 21.03
Component: Core Version:
Keywords: Cc: stoecker

Description

$ java -jar josm-latest.jar --status-report

Revision:17630
Is-Local-Build:true
Build-Date:2021-03-21 22:03:41

Identification: JOSM/1.5 (17630 SVN en) Mac OS X 11.2.3
OS Build number: macOS 11.2.3 (20D91)
Memory Usage: 128 MB / 2048 MB (117 MB allocated, but free)
Java version: 16+36, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 1 1440×900 (scaling 2,00×2,00) Display 2 3008×1692 (scaling 2,00×2,00)
Maximum Screen Size: 3008×1692
Best cursor sizes: 16×16→16×16, 32×32→32×32
Program arguments: [--status-report]

Attachments (0)

Change History (15)

comment:1 Changed 14 months ago by simon04

Resolution: fixed
Status: assignedclosed

In 17637/josm:

fix #20647 - Add --status-report command line argument

comment:3 Changed 14 months ago by skyper

man page?

comment:4 Changed 14 months ago by simon04

In 17638/josm:

see #20647 - Add --status-report to man pages

comment:5 Changed 14 months ago by Don-vip

In 17641/josm:

see #20647 - adjust man date

comment:6 Changed 14 months ago by skyper

man page was not updated:

man josm-latest
  • no --status-report
  • date is still July 21, 2016
josm-latest --version
Using /usr/lib/jvm/java-11-openjdk-amd64/bin/java to execute josm-latest.
JOSM/1.5 (17653 en) Linux Debian GNU/Linux 10 (buster)

comment:7 Changed 14 months ago by skyper

Resolution: fixed
Status: closedreopened

man page is still not up to date:

Using /usr/lib/jvm/java-11-openjdk-amd64/bin/java to execute josm-latest.
Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-03-25 01:56:53 +0100 (Thu, 25 Mar 2021)
Revision:17663
Build-Date:2021-03-25 02:30:59
URL:https://josm.openstreetmap.de/svn/trunk

comment:8 Changed 14 months ago by simon04

How does the updated man page end up in https://josm.openstreetmap.de/apt/pool/universe/j/josm-latest/josm-latest_1.5.svn17664_all.deb – is a manual interaction on the build server required?

comment:9 Changed 14 months ago by Don-vip

No, I thought it was automatic. I'm checking.

comment:10 Changed 14 months ago by Don-vip

Cc: stoecker added
Resolution: fixed
Status: reopenedclosed

"Fixed". The SVN repo did not update itself, I did the update manually. @Dirk I'm sending you an e-mail, I don't know the root cause.

comment:11 Changed 14 months ago by simon04

Thank you for keeping the build system wheels running :)

comment:12 Changed 14 months ago by skyper

Yes, thanks for all the background work.

comment:13 Changed 14 months ago by skyper

Running josm-latest --status-report while josm-latest is already running, corrupts preferences.xml.

comment:14 Changed 14 months ago by skyper

Resolution: fixed
Status: closedreopened

Oh no, it always corrupts the preferences and does not show the correct info.

comment:15 Changed 14 months ago by simon04

Resolution: fixed
Status: reopenedclosed

In 17668/josm:

fix #20647 - Do not corrupt preferences when using --status-report

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.