Modify

Opened 14 months ago

Closed 14 months ago

Last modified 13 months ago

#20626 closed enhancement (fixed)

Update to OpeningHoursParser 0.23.2

Reported by: simon04 Owned by: simon04
Priority: normal Milestone: 21.03
Component: Core validator Version:
Keywords: opening_hours Cc: SimonPoole

Description

https://github.com/simonpoole/OpeningHoursParser/releases/tag/0.23.0

  • The parser now supports limited restarting and can return multiple parse exceptions
  • In non-strict mode minute value parsing is more lenient, in particular with respect to additional white space and superfluous leading zeros
  • Fix list of date ranges with occurrence in month don't work
  • Support of EM DASH (U+2014) as a hyphen character

Attachments (0)

Change History (11)

comment:1 Changed 14 months ago by simon04

Owner: changed from team to simon04
Status: newassigned

comment:2 Changed 14 months ago by simon04

Resolution: fixed
Status: assignedclosed

In 17590/josm:

fix #20626 - Update to OpeningHoursParser 0.23.0

comment:3 Changed 14 months ago by simon04

In 17591/josm:

see #20626 - OpeningHoursParser: report multiple parse exceptions

comment:4 Changed 14 months ago by simon04

Resolution: fixed
Status: closedreopened
Summary: Update to OpeningHoursParser 0.23.0Update to OpeningHoursParser 0.23.1

comment:5 Changed 14 months ago by simon04

Resolution: fixed
Status: reopenedclosed

In 17647/josm:

fix #20626 - Update to OpeningHoursParser 0.23.1

comment:6 Changed 14 months ago by simon04

Resolution: fixed
Status: closedreopened
Summary: Update to OpeningHoursParser 0.23.1Update to OpeningHoursParser 0.23.2

comment:7 Changed 14 months ago by simon04

Resolution: fixed
Status: reopenedclosed

In 17683/josm:

fix #20626 - Update to OpeningHoursParser 0.23.2

comment:8 Changed 13 months ago by skquinn

This appears to have broken/disabled the automatic fixing that worked in previous versions. Was this intentional?

comment:9 in reply to:  8 Changed 13 months ago by skyper

Replying to skquinn:

This appears to have broken/disabled the automatic fixing that worked in previous versions.

An example, please. Note that not all warnings are auto-fixable.

comment:10 Changed 13 months ago by skquinn

Three character weekdays and am/pm were automatically fixable before, and are not now.

I get that some of the more complicated ways people have found to screw up opening_hours and related tags will not be automatically fixable; these were trivial fixes (but very tedious to do by hand).

comment:11 Changed 13 months ago by simon04

@skquinn, I cannot reproduce.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.