Modify

Opened 14 years ago

Closed 14 years ago

#2058 closed defect (fixed)

[1298] by ulfl breaks relation workflow: Currently selected objects are deselected when adding relation tags

Reported by: avarab@… Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Steps to reproduce

  1. Create a node or way and have it selected
  2. Open the "create a new relation" dialog
  3. Press the the "key" text field to add a new key
  4. The currently selected object(s) will be unselected

This means when creating e.g. a new multipolygon one has to select all the relevant ways, open the "create a new relation" dialog, immediately click "Add selected" and then proceed to add key/value pairs to the relation. This is unintuitive.

Attachments (0)

Change History (3)

comment:1 Changed 14 years ago by avarab@…

Summary: Recent JOSM change breaks relation workflow: Currently selected objects are deselected when adding relation tags[1298] by ulfl breaks relation workflow: Currently selected objects are deselected when adding relation tags

This was caused by [1298]

comment:2 Changed 14 years ago by pieren

Priority: minormajor

It is not deselecting all objects when you press the "key" test field but immediately when you open the relation editor when you click on "new" relation.

Also, if you select one key/value, all objects are selected. If you press the "delete" button, it is not the key/value which is deleted but one of the attached members.

comment:3 Changed 14 years ago by anonymous

Resolution: fixed
Status: newclosed

The selection handling is fixed in r1331. Nevertheless the Relation Editor needs some cleanup in user interface (like the ambigous delete button handling).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.