Modify

Opened 9 months ago

Closed 9 months ago

#20567 closed defect (duplicate)

ClassNotFoundException: java.sql.Time

Reported by: anonymous Owned by: jBeata
Priority: normal Milestone:
Component: Plugin Kartaview/openstreetcam Version:
Keywords: template_report webstart Cc:

Description

What steps will reproduce the problem?

  1. Run josm.jnlp with OpenWebStart 1.3.3
  2. Click "Yes" to Update Plugins
  3. Keep "geotools" plugin even though the update can't be found

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-12-28 22:03:23 +0100 (Mon, 28 Dec 2020)
Revision:17428
Build-Date:2020-12-30 02:30:55
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17428 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2009 (19042)
Memory Usage: 200 MB / 2048 MB (80 MB allocated, but free)
Java version: 14.0.1+7, AdoptOpenJDK, OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
VM arguments: [-Dicedtea-web.bin.location=D:\Program Files\OpenWebStart\javaws, --add-modules=java.scripting,java.sql, --add-exports=java.desktop/com.apple.eawt=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=javafx.graphics/com.sun.javafx.application=ALL-UNNAMED, --add-exports=jdk.deploy/com.sun.deploy.config=ALL-UNNAMED, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-opens=java.base/java.nio=ALL-UNNAMED, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, -Djava.util.Arrays.useLegacyMergeSort=true, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop,jdk.jsobject, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-reads=java.base=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop,ALL-UNNAMED, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop,ALL-UNNAMED, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop]

Plugins:
+ BuildingGeneralization
+ CustomizePublicTransportStop
+ ImportImagePlugin
+ Mapillary
+ OpenStreetCam
+ OpeningHoursEditor
+ PicLayer
+ SeaChart
+ SeaMapEditor (35543)
+ apache-commons (35524)
+ apache-http (35589)
+ buildings_tools
+ continuosDownload
+ ejml (35458)
+ geotools
+ imagery_offset_db
+ jaxb (35543)
+ jna (35662)
+ jts (35458)
+ log4j (35458)
+ measurement (35640)
+ opendata (35640)
+ pdfimport
+ reverter (35688)
+ routing
+ turnrestrictions
+ undelete
+ utilsplugin2 (35691)
+ wikipedia

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Disc_Golf_Course&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/US.zip

Last errors/warnings:
- 00000.330 W: extended font config - overriding 'filename.Myanmar_Text=mmrtext.ttf' with 'MMRTEXT.TTF'
- 00000.334 W: extended font config - overriding 'filename.Mongolian_Baiti=monbaiti.ttf' with 'MONBAITI.TTF'
- 00002.814 W: Update plugins - Last plugin update more than 63 days ago.
- 00015.356 W: java.io.IOException: The requested URL https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1 was not found
- 00015.471 E: java.io.IOException: No file found for: https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
- 00015.472 E: https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
- 00017.419 E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin geotools. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoClassDefFoundError: javax/sql/DataSource. Cause: java.lang.ClassNotFoundException: javax.sql.DataSource
- 00017.429 W: Disable plugin - Could not load plugin 'geotools'. Delete from preferences?
- 00024.961 E: Handled by bug report queue: java.lang.NoClassDefFoundError: java/sql/Time. Cause: java.lang.ClassNotFoundException: java.sql.Time



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-3-thread-1 (88)
java.lang.NoClassDefFoundError: java/sql/Time
	at com.google.gson.Gson.<init>(Gson.java:241)
	at com.google.gson.GsonBuilder.create(GsonBuilder.java:545)
	at org.openstreetmap.josm.plugins.openstreetcam.service.photo.OpenStreetCamService.createGson(OpenStreetCamService.java:60)
	at org.openstreetmap.josm.plugins.openstreetcam.service.BaseService.<init>(BaseService.java:50)
	at org.openstreetmap.josm.plugins.openstreetcam.service.photo.OpenStreetCamService.<init>(OpenStreetCamService.java:49)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.SearchServiceHandler.<init>(SearchServiceHandler.java:57)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.ServiceHandler.<init>(ServiceHandler.java:49)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.ServiceHandler.<clinit>(ServiceHandler.java:54)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.generateSigns(DetectionTypeContent.java:44)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.<init>(DetectionTypeContent.java:35)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.<clinit>(DetectionTypeContent.java:32)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630)
	at java.base/java.lang.Thread.run(Thread.java:832)
Caused by: java.lang.ClassNotFoundException: java.sql.Time
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:435)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:589)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
	... 14 more

Attachments (0)

Change History (2)

comment:1 Changed 9 months ago by Don-vip

Component: CorePlugin openstreetcam
Keywords: webstart added
Owner: changed from team to jBeata
Summary: Updating Plugins Causes Exception?ClassNotFoundException: java.sql.Time

comment:2 Changed 9 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17673.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jBeata.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.