Modify

Opened 2 weeks ago

Closed 2 weeks ago

#20525 closed defect (duplicate)

Plug-in bug

Reported by: anonymous Owned by: jBeata
Priority: normal Milestone:
Component: Plugin openstreetcam Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. download verious plug-ins for the first time

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-12-28 22:03:23 +0100 (Mon, 28 Dec 2020)
Revision:17428
Build-Date:2020-12-30 02:30:55
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17428 en) Linux Mint 20.1
Memory Usage: 370 MB / 2048 MB (153 MB allocated, but free)
Java version: 11.0.10+9-Ubuntu-0ubuntu1.20.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1366×768 (scaling 1.00×1.00)
Maximum Screen Size: 1366×768
Best cursor sizes: 16×16→16×16, 32×32→32×32
Desktop environment: X-Cinnamon
Java package: openjdk-11-jre:amd64-11.0.10+9-0ubuntu1~20.04
WebStart package: icedtea-netx:amd64-1.8-0ubuntu8
Environment variable LANG: en_US.UTF-8
libcommons-compress-java: libcommons-compress-java:all-1.19-1
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20200323-1build1~ubuntu20.04.1
liboauth-signpost-java: liboauth-signpost-java:all-1.2.1.2-3
VM arguments: [--add-reads=java.base=ALL-UNNAMED,java.desktop, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,jdk.jsobject, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, -Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/lib/icedtea-web/bin/javaws]

Plugins:
+ DirectDownload (35640)
+ ElevationProfile (35640)
+ FixAddresses (35640)
+ ImproveOsm (203)
+ OpenStreetCam (356)
+ apache-commons (35524)
+ auto_tools (73)
+ contourmerge (v0.1.6)
+ dataimport (35640)
+ ejml (35458)
+ geohash (80)
+ jaxb (35543)
+ jts (35458)
+ livegps (35640)
+ measurement (35640)
+ merge-overlap (35640)
+ microdata_scraping (1608227152)
+ o5m (35640)
+ opendata (35640)
+ scripting (30798)
+ surveyor (35640)
+ utilsplugin2 (35691)

Last errors/warnings:
- 00030.307 E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin geotools. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoClassDefFoundError: javax/sql/DataSource. Cause: java.lang.ClassNotFoundException: javax.sql.DataSource
- 00030.379 W: Disable plugin - Could not load plugin 'geotools'. Delete from preferences?
- 00070.665 E: Handled by bug report queue: java.lang.NoClassDefFoundError: java/sql/Time. Cause: java.lang.ClassNotFoundException: java.sql.Time



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-2-thread-1 (60)
java.lang.NoClassDefFoundError: java/sql/Time
	at com.google.gson.Gson.<init>(Gson.java:241)
	at com.google.gson.GsonBuilder.create(GsonBuilder.java:545)
	at org.openstreetmap.josm.plugins.openstreetcam.service.photo.OpenStreetCamService.createGson(OpenStreetCamService.java:60)
	at org.openstreetmap.josm.plugins.openstreetcam.service.BaseService.<init>(BaseService.java:50)
	at org.openstreetmap.josm.plugins.openstreetcam.service.photo.OpenStreetCamService.<init>(OpenStreetCamService.java:49)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.SearchServiceHandler.<init>(SearchServiceHandler.java:57)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.ServiceHandler.<init>(ServiceHandler.java:49)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.ServiceHandler.<clinit>(ServiceHandler.java:54)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.generateSigns(DetectionTypeContent.java:44)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.<init>(DetectionTypeContent.java:35)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.<clinit>(DetectionTypeContent.java:32)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ClassNotFoundException: java.sql.Time
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:589)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
	... 14 more

Attachments (0)

Change History (1)

comment:1 Changed 2 weeks ago by skyper

Component: CorePlugin openstreetcam
Owner: changed from team to jBeata
Resolution: duplicate
Status: newclosed

Closed as duplicate of #17673.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jBeata.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.