Modify

Opened 5 weeks ago

Closed 5 weeks ago

Last modified 3 weeks ago

#20435 closed defect (fixed)

Allow area:highway + bridge=yes

Reported by: mkoniecz Owned by: Don-vip
Priority: normal Milestone: 21.02
Component: Core validator Version:
Keywords: template_report bridge area highway Cc:

Description

What steps will reproduce the problem?

  1. validate https://www.openstreetmap.org/way/508797754

What is the expected result?

Nothing.

What happens instead?

bridge on suspicious object (2)

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-01-09 17:11:18 +0100 (Sat, 09 Jan 2021)
Revision:17451
Build-Date:2021-01-10 02:30:49
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17451 en_GB) Linux Ubuntu 20.04.1 LTS
Memory Usage: 692 MB / 976 MB (245 MB allocated, but free)
Java version: 11.0.9.1+1-Ubuntu-0ubuntu1.20.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Desktop environment: LXQt
Java package: openjdk-11-jre:amd64-11.0.9.1+1-0ubuntu1~20.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
Environment variable LANG: en_GB.UTF-8
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (35669)
+ reverter (35688)
+ todo (30306)

Last errors/warnings:
- 00349.043 W: Conflicts detected - <html>There were 4 conflicts detected.</html>
- 02015.438 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 02015.441 E: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 02015.455 E: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 02015.466 E: IO Exception - <html>Failed to upload data to or download data from<br>'https://overpass-api.de/api/interpreter'<br>due to a problem with transferring data.<br>Details (untranslated): Read timed out</html>
- 02552.322 E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- 02552.332 E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>

Attachments (0)

Change History (3)

comment:1 Changed 5 weeks ago by Don-vip

Keywords: bridge area highway added
Milestone: 21.01
Owner: changed from team to Don-vip
Status: newassigned

comment:2 Changed 5 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 17481/josm:

fix #20435 - allow area:highway in "suspicious tag combination"

comment:3 Changed 3 weeks ago by stoecker

Milestone: 21.0121.02

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.