Modify

Opened 7 days ago

Closed 2 days ago

Last modified 2 days ago

#20369 closed defect (fixed)

Dont load images if pref="load if manually ordered"

Reported by: MKnight Owned by: taylor.smock
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report manual order Cc:

Description

What steps will reproduce the problem?

  1. load some osm-data
  2. activate mapillary-layer
  3. load images via [Shift]+.
  4. load other data

What is the expected result?

Dont load images at 4.

What happens instead?

on load other osm-data mapillary loads images again

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-12-28 22:03:23 +0100 (Mon, 28 Dec 2020)
Revision:17428
Build-Date:2020-12-30 02:30:55
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17428 de) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 607 MB / 4000 MB (182 MB allocated, but free)
Java version: 11.0.5+10, AdoptOpenJDK, OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsClassicLookAndFeel
Screen: \Display0 1920×1080 (scaling 1,00×1,00) \Display1 1280×1024 (scaling 1,00×1,00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
Program arguments: [de-josm.joz]
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.34)
+ apache-commons (35524)
+ apache-http (35589)
+ buildings_tools (35669)
+ continuosDownload (91)
+ ejml (35458)
+ geotools (35458)
+ gridify (1606242219)
+ imagery_offset_db (35640)
+ jna (35662)
+ jogl (1.2.3)
+ jts (35458)
+ log4j (35458)
+ reltoolbox (35640)
+ reverter (35640)
+ utilsplugin2 (35674)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Addr2&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Maxspeed-zones&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ https://raw.github.com/Flacus/Windrad/master/windrad.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/NewParkingFeatures&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
+ C:\OSm\JOSM\eigene-style.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1
+ https://github.com/osmlab/appledata/archive/josm_paint_inline_validation.zip
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1

Last errors/warnings:
- 00040,327 E: Fehler beim Laden des Bildes 'regulatory--texts--g1'
- 00040,329 E: Fehler beim Laden des Bildes 'regulatory--texts--g2'
- 00040,608 E: Fehler beim Laden des Bildes 'void--car-mount'
- 00040,611 E: Fehler beim Laden des Bildes 'void--dynamic'
- 00040,613 E: Fehler beim Laden des Bildes 'void--ego-vehicle'
- 00040,616 E: Fehler beim Laden des Bildes 'void--ground'
- 00040,618 E: Fehler beim Laden des Bildes 'void--static'
- 00040,943 E: Fehler beim Laden des Bildes 'warning--kangaroo-crossing--g1'
- 01694,679 E: java.io.IOException: stream is closed
- 01700,975 E: Unknown detection "information--rest-area--g1"

Attachments (0)

Change History (8)

comment:1 Changed 7 days ago by skyper

Keywords: manual order added
Version: tested

comment:2 Changed 3 days ago by taylor.smock

Resolution: fixed
Status: newclosed

comment:3 Changed 2 days ago by MKnight

Resolution: fixed
Status: closedreopened

There is no change in the behavior at me:

Josm-version 17428 (tested) (on latest, the plugin is crashing)
Mapillary 1.5.36.2 (latest)
Prefs in the plugin:

only if manually ordered
use 24h-format
center Position on new image

Maybe my Description is not good enough?

what i want: load mapillary-images at [shift+.] one time if pressed.
After that, load images only if [shift+.] is pressed again. Not on download OSM-Data or other.

comment:4 Changed 2 days ago by taylor.smock

Resolution: fixed
Status: reopenedclosed

I point at the commit where I fixed the problem. Depending upon severity, this does not mean I've made a release with the fix.

That being said, I thought I released v1.5.36.3 yesterday, but it looks like I failed to save the page.

comment:5 Changed 2 days ago by taylor.smock

For Josm latest, I know about the crash (I just need to recompile the plugin). This is due to a Josm core change that will make the plugin much more responsive with many downloaded images.
The reason for the crash is that the method interface changed. I'd point at the ticket, but I'm on mobile right now.

comment:6 Changed 2 days ago by MKnight

Ok, thx.

comment:7 in reply to:  5 Changed 2 days ago by taylor.smock

Replying to taylor.smock:
See #20363 for the change that broke Mapillary on JOSM latest (I've recompiled the Mapillary plugin for it, and it should show up when you update plugins in ~10 minutes).

comment:8 Changed 2 days ago by MKnight

It works! Thx :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain taylor.smock.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.