Modify

Opened 2 months ago

Closed 7 days ago

#20344 closed defect (fixed)

Failed to register with OSX: IAE: class PlatformHookOsx cannot access class com.apple.eawt.Application (in module java.desktop)

Reported by: cyigit97@… Owned by: Don-vip
Priority: critical Milestone: 21.02
Component: Installer MacOS Version: latest
Keywords: template_report macOS java16 Cc:

Description

What steps will reproduce the problem?

  1. Select any object from the downloaded map data (in my case a boundary) which is part of a relation.
  2. Go to the attributes section of JOSM on the right and select any relation within it.
  3. Right-click on any relation.
  4. Choose edit

What is the expected result?

The relation editor to function.

What happens instead?

The app gets completely unresponsive and you have to force quit. I cannot edit relations with JOSM on macOS at all in the moment.

Please provide any additional information below. Attach a screenshot if possible.

Revision:17428
Is-Local-Build:true
Build-Date:2020-12-28 22:07:16

Identification: JOSM/1.5 (17428 SVN de) Mac OS X 10.16
OS Build number: macOS 11.1 (20C69)
Memory Usage: 260 MB / 8192 MB (83 MB allocated, but free)
Java version: 16-ea+29, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69934516 2560×1440 (scaling 2.00×2.00)
Maximum Screen Size: 2560×1440
Best cursor sizes: 16×16→16×16, 32×32→32×32
VM arguments: [-Djpackage.app-version=17428, -Dapple.awt.application.appearance=system, -Djpackage.app-path=/Applications/JOSM.app/Contents/MacOS/JOSM]

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Last errors/warnings:
- 00002.138 W: Failed to register with OSX: java.lang.IllegalAccessException: class org.openstreetmap.josm.tools.PlatformHookOsx cannot access class com.apple.eawt.Application (in module java.desktop) because module java.desktop does not export com.apple.eawt to unnamed module @4b3a45f1

Attachments (0)

Change History (7)

comment:1 Changed 2 months ago by Don-vip

Owner: changed from team to cyigit97@…
Status: newneedinfo

How do you launch JOSM?

comment:2 Changed 2 months ago by cyigit97@…

I start it regularly from the dock or the launchpad. But I don’t think that’s the cause of the issue as the app starts and performs normally, until you want to use the relation editor.

comment:3 Changed 13 days ago by Stereo

Keywords: macOS regression added

I see you're using the java 16 build. Does this also happen in the "normal" java 15 build, https://github.com/grischard/josm/releases/download/17428-tested/JOSM-macOS-java15.zip? I can't reproduce this in either java 15 or 16.

Are you running in full screen or anything special?

comment:4 Changed 7 days ago by Don-vip

Component: CoreInstaller MacOS
Keywords: java16 added; regression removed
Milestone: 21.02
Owner: changed from cyigit97@… to Don-vip
Status: needinfoassigned

comment:5 Changed 7 days ago by Don-vip

Java 16 switched to strong encapsulation by default (see https://openjdk.java.net/jeps/396) and I don't see any add-export directive when we call jpackage in macos-package.sh so the build has about 0% chance to work correctly.

Last edited 7 days ago by Don-vip (previous) (diff)

comment:6 Changed 7 days ago by Don-vip

Summary: Relation editor brings app to hang-up and be unusable on macOSFailed to register with OSX: IAE: class PlatformHookOsx cannot access class com.apple.eawt.Application (in module java.desktop)

comment:7 Changed 7 days ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 17546/josm:

see #19724 - fix #20344 - add add-opens/add-exports directive from JNLP file to macOS build

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.