Modify

Opened 8 weeks ago

Closed 8 weeks ago

#20336 closed defect (invalid)

JOSM.exe does not choose latest Java version

Reported by: Uve.S@… Owned by: team
Priority: minor Milestone:
Component: Installer Windows Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. I upgraded Java Runtime Environment from 10.0.2 to 1.8.271 (both 64 bit)
  2. I upgraded JOSM to 17428 by latest JOSM-setup.exe
  3. I am launching JOSM by double-cklicking JOSM.exe

What is the expected result?

josm-tested.jar should be run with latest Java 8u271.

What happens instead?

But JOSM.exe chooses out-of-date Java 10.0.2.

Please provide any additional information below. Attach a screenshot if possible.

When double-clicking josm-tested.jar directly in Windows Exlorer, the right Java 1.8.271 is called. On the other hand, text looks very blurred in Java 8u271, so I will downgrade to 10.0.2 anyway.

launch4j.log
Version: 3.10
CmdLine: E:\JOSM\josm.exe --l4j-debug
WOW64: yes
Java min ver: 1.8.0
Java max ver:
64-bit search: SOFTWARE\JavaSoft\Java Runtime Environment...
Check: SOFTWARE\JavaSoft\Java Runtime Environment\1.8
Ignore: 1.8
Check: SOFTWARE\JavaSoft\Java Runtime Environment\1.8.0_271
Check launcher: E:\Java\JRE1.8.271\bin\javaw.exe (OK)
Match: 1.8.0_271
64-bit search: SOFTWARE\JavaSoft\Java Development Kit...
64-bit search: SOFTWARE\JavaSoft\JRE...
Check: SOFTWARE\JavaSoft\JRE\10.0.2
Check launcher: E:\Java\JRE10.0.2\bin\javaw.exe (OK)
Match: 10.0.2
64-bit search: SOFTWARE\JavaSoft\JDK...
Runtime used: 10.0.2 (64-bit)
Heap -Xms: Requested 256 MB / 0%, Available: 2982 MB, Heap size: 256 MB
Heap -Xmx: Requested 2048 MB / 0%, Available: 2982 MB, Heap size: 2048 MB
Launcher: E:\Java\JRE10.0.2\bin\javaw.exe
Launcher args: -Xms256m -Xmx2048m -jar "E:\JOSM\josm-tested.jar"
Args length: 49/32768 chars
Exit code: 0

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-12-28 22:03:23 +0100 (Mon, 28 Dec 2020)
Build-Date:2020-12-29 02:30:53
Revision:17428
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17428 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1909 (18363)
Memory Usage: 872 MB / 1820 MB (542 MB allocated, but free)
Java version: 1.8.0_271-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 2736×1824 (scaling 1.00×1.00)
Maximum Screen Size: 2736×1824
Best cursor sizes: 16×16→32×32, 32×32→32×32
Dataset consistency test: No problems found

Plugins:
+ imagery_offset_db (35640)
+ turnrestrictions (35640)

Last errors/warnings:
- 01085.970 E: Failed to locate image 'Block, Green'
- 01085.980 E: Failed to locate image 'Block, Red'
- 01085.982 E: Failed to locate image 'Block, Blue'

Attachments (1)

launch4j.log (956 bytes) - added by Uve.S@… 8 weeks ago.
log file of JOSM.exe

Download all attachments as: .zip

Change History (3)

Changed 8 weeks ago by Uve.S@…

Attachment: launch4j.log added

log file of JOSM.exe

comment:1 Changed 8 weeks ago by skyper

Actually, 10.0.2 is a higher version than 1.8.271 but 10 has already been superseded by higher versions. For HiDPI you need 9 or later, see Help/HiDPISupport.

Please, make sure to completely uninstall one java version before installing a new one. Otherwise, you might need to manually set the version to use.

In your case, JOSM uses the highest available version which seems to be correct.

comment:2 Changed 8 weeks ago by Don-vip

Resolution: invalid
Status: newclosed

Keep only one version of Java installed, you have these choices:

  • 8u275 (LTS)
  • 11.0.9.1 (LTS)
  • 15.0.1 (non LTS: you have to update to 16 when it's released, then 17 which will be the next LTS)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.