Modify

Opened 2 months ago

Closed 2 months ago

Last modified 7 weeks ago

#20327 closed defect (duplicate)

Couldn't get the newest version of JOSM (MacOS)

Reported by: yafizakaria97@… Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: template_report Cc: Stereo

Description

What steps will reproduce the problem?

  1. Direct download from the JOSM website which said it has version 17428
  2. Downloaded it
  3. When I open it, it says 17329

What is the expected result?

Updated to the newest version

What happens instead?

Got the old update instead

Please provide any additional information below. Attach a screenshot if possible.

Revision:17329
Is-Local-Build:true
Build-Date:2020-11-22 22:31:51

Identification: JOSM/1.5 (17329 SVN en) Mac OS X 10.15.3
OS Build number: Mac OS X 10.15.3 (19D76)
Memory Usage: 404 MB / 8192 MB (70 MB allocated, but free)
Java version: 15.0.1+9, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69732992 1280x800 (scaling 2.0x2.0)
Maximum Screen Size: 1280x800
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
VM arguments: [-Dapple.awt.application.appearance=system, --module-path=/private/var/folders/nc/9f3z034j7pv25h12dh_jhnhc0000gn/T/AppTranslocation/5D1EC5E5-8DAF-4023-882D-B9DCAC36F0BD/d/JOSM.app/Contents/app/mods]

Plugins:
+ FastDraw
+ HouseNumberTaggingTool
+ ImproveWay
+ PicLayer
+ buildings_tools
+ continuosDownload
+ importvec
+ measurement
+ reverter
+ splinex
+ utilsplugin2

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Mountains&zip=1
- https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1

Last errors/warnings:
- 00005.854 W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>continuosDownload</li><li>ImproveWay</li><li>utilsplugin2</li><li>HouseNumberTaggingTool</li><li>splinex</li><li>buildings_tools</li><li>importvec</li><li>reverter</li><li>measurement</li><li>FastDraw</li><li>PicLayer</li></ul>The plugins are not going to be loaded.</html>

OSM API: http://opengeofiction.net/api

Attachments (0)

Change History (4)

comment:1 Changed 2 months ago by Klumbumbus

Cc: Stereo added

comment:2 Changed 2 months ago by Stereo

Hi, yes, Dirk or Vincent need to update the link.

For now, grab it at https://github.com/grischard/josm/releases/download/17428-tested/JOSM-macOS-java15.zip

comment:3 Changed 2 months ago by Stereo

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20146.
See also #20146

comment:4 Changed 7 weeks ago by Stereo

For anyone keeping track, the josm website link has been updated :).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.