Modify

Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#20238 closed defect (fixed)

update multipolygon on old-style multipolygon action cannot be fully undone

Reported by: GerdP Owned by: GerdP
Priority: normal Milestone: 20.12
Component: Core Version: tested
Keywords: template_report multipolygon regression Cc:

Description

What steps will reproduce the problem?

  1. Load attached file with an old style multipolygon
  2. Select the way and press Ctrl+Shift+B to update the multipolygon
  3. Undo

What is the expected result?

no changes in way or relation

What happens instead?

relation has tag building=yes (as well as the building)

Please provide any additional information below. Attach a screenshot if possible.

Build-Date:2020-12-13 12:15:19
Revision:17405
Is-Local-Build:true

Identification: JOSM/1.5 (17405 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 796 MB / 1820 MB (438 MB allocated, but free)
Java version: 1.8.0_272-b10, AdoptOpenJDK, OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
VM arguments: [-agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:60338, -ea, -javaagent:D:\eclipse-java-2020-09\eclipse\configuration\org.eclipse.osgi\215\0\.cp\lib\javaagent-shaded.jar, -Dfile.encoding=UTF-8]

Plugins:
+ ColumbusCSV (35640)
+ buildings_tools (35669)
+ o5m (35640)
+ pbf (35650)
+ poly (35640)
+ reltoolbox (35640)
+ reverter (35640)
+ undelete (35640)
+ utilsplugin2 (35671)

Validator rules:
+ c:\josm\core\resources\data\validator\geometry.mapcss

Attachments (1)

data.osm (793 bytes) - added by GerdP 5 weeks ago.

Download all attachments as: .zip

Change History (5)

Changed 5 weeks ago by GerdP

Attachment: data.osm added

comment:1 Changed 5 weeks ago by GerdP

Owner: changed from team to GerdP
Status: newassigned

comment:2 Changed 5 weeks ago by GerdP

Keywords: multipolygon regression added

regression of r15160, since then no change command for the relation was created

comment:3 Changed 5 weeks ago by GerdP

Resolution: fixed
Status: assignedclosed

In 17408/josm:

fix #20238: update multipolygon on old-style multipolygon action cannot be fully undone

  • make sure that a command to update the relation is generated
  • add unit test

comment:4 Changed 5 weeks ago by GerdP

Milestone: 20.12
Version: latesttested

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.