Modify

Opened 17 months ago

Closed 14 months ago

Last modified 7 months ago

#20233 closed enhancement (fixed)

Session: export/import (gpx/marker) layer color

Reported by: ra@… Owned by: simon04
Priority: normal Milestone: 21.03
Component: Core Version:
Keywords: project color joz transparency markers Cc:

Description

Hi,
It would be a big improvement for me, and doubtless others, if when saving a project to a joz file
the transparency of the markers in a gpx file (for wav and jpg files in particular) were also saved and reproduced when subsequently opening the joz file.
I always set the transparency to be full so that I can't see the name and description of the waypoint, most of which are identical to one another. The name and description can be very long, and when there are many markers they are far too obtrusive when not set to fully-transparent.
Please consider this as a very worthwhile enhancement. I suspect the coding and testing for it won't be too onerous.
Thanks.
Rob

Attachments (4)

2021-01-07 - Shuttle-Green Chain.joz (16.9 KB) - added by anonymous 14 months ago.
Screenshot 1.jpg (678.1 KB) - added by anonymous 14 months ago.
Screenshot 2.jpg (703.6 KB) - added by anonymous 14 months ago.
Status report.txt (29.7 KB) - added by anonymous 14 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 14 months ago by simon04

Owner: changed from team to ra@…
Status: newneedinfo

Layer opacity is saved to the JOZ file, see #4029 and r5551.

Please add a test file and a screenshot.


Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.


Changed 14 months ago by anonymous

Changed 14 months ago by anonymous

Attachment: Screenshot 1.jpg added

Changed 14 months ago by anonymous

Attachment: Screenshot 2.jpg added

comment:2 Changed 14 months ago by ra@…

I'm sorry that my ticket wasn't helpful in its current form.

I think you're saying that what I'm describing is a bug because the 'enhancement' is already in place. I hope the following may help:

The layer in question is called "Markers from [filename].gpx". When that layer is set to full transparency/zero opacity I can see the icons but not the text. This is how I want it to be when restored from the .joz file.
Instead, when restored, the text in the layer is visible (with zero transparency/full opacity).

I've looked at https://josm.openstreetmap.de/changeset/5551/josm but I don't do coding and this is all gobbledegook to me and don't know what to make of it. Same with https://josm.openstreetmap.de/ticket/4029.

I've attached an example .joz file. I assume this is the test file you're asking for. I've also attached a screenshot as it is before saving as .joz and one showing how it is on restoring from .joz. I hope this is what you were after.

Regards,
Rob

comment:3 Changed 14 months ago by skyper

Well, it is still some kind of guessing and a step by step description including the status report is always helpful.

What I can say is that the color settings of the marker layer is not saved in the session file:

  1. Open session
  2. Set maker layer color to black an alpha to zero
  3. Save session
  4. Delete all layers
  5. Load session
  6. Color settings are gone
Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-03-23 00:59:25 +0100 (Tue, 23 Mar 2021)
Revision:17645
Build-Date:2021-03-23 02:30:55
URL:https://josm.openstreetmap.de/svn/trunk
Last edited 14 months ago by skyper (previous) (diff)

comment:4 Changed 14 months ago by simon04

@ra, please confirm that skyper's steps reproduce the behaviour you want to get fixed. Nothing is more annoying than spending some time (an hour) to fix an issue which turns out to be a different than the original reporter meant.

Changed 14 months ago by anonymous

Attachment: Status report.txt added

comment:5 Changed 14 months ago by ra@…

Hi, and thanks for your responses.
I provided a file and screen shot as requested and regarded the other items as forming a standard reply that didn’t need repeating or adding (as the case may be). My mistake.
I’ll try and be more specific.
Thanks, simon04, for explaining that skyper was asking me to carry out those specific steps. I took it to be that he/she had carried out those steps for him/herself and found the same problem.
I did my own list of steps to send following that response and then saw your (simon04’s) last request, so I’ve gone back and done what skyper’s listed.
I’m not clear whether you want further screen shots. I’ll assume not for now.
I’m attaching the status report from my Windows 10 machine. I’ve included it all as I don’t know which part(s) of it you may need. If it’s going to help I can do the same from my old Windows XP machine, which exhibits the same problem, and on which I do most of my JOSM work.
So, as you (skyper) requested:

  1. Open session: Displays track and markers with icons and magenta text (as previous screenshot (which also showed aerial imagery)).
  2. Set marker layer colour to black and alpha to zero: Done. I also added an imagery layer to check whether the text was visible or not. Text is not visible.
  3. Save session: Done, as .joz file, saving all layers.
  4. Delete all layers: Done.
  5. Load session: Done, using File, Open. Displays track and markers with icons and magenta text.
  6. Colour settings are gone: Correct. They’ve reverted to how they were before setting the markers layer to black and transparent.

I hope this all helps to be more precise about the problem and the circumstances around it. If you need more info or tests please let me know.
Thanks to both for what you do for JOSM.
Regards,
Rob

comment:6 Changed 14 months ago by simon04

Milestone: 21.03
Owner: changed from ra@… to simon04
Status: needinfoassigned

comment:7 Changed 14 months ago by simon04

In 17658/josm:

see #20233 - SessionWriterTest.testWriteGpxAndMarkerJoz

comment:8 Changed 14 months ago by simon04

Resolution: fixed
Status: assignedclosed

In 17659/josm:

fix #20233 - Session: export/import layer color

comment:9 Changed 14 months ago by simon04

Summary: Saving transparency in joz fileSession: export/import (gpx/marker) layer color

comment:10 Changed 14 months ago by simon04

Keywords: color added; colour removed

comment:11 Changed 7 months ago by Don-vip

In 18287/josm:

fix #20913 - fix handling of GPX files in sessions (patch by Bjoeni)

  • revert r17659 (except for unit tests) - see #20233
    • don't save GPX track and marker colors in session file anymore, but in the GPX files as extensions (like before)
    • don't ask to save unmodified GPX file
    • don't override global color settings when individual track doesn't have a color
  • ask user to save changes to GPX file when any drawing settings or marker colors have changed (currently only happens for track colors)
  • save marker color values to session even when corresponding GPX layer has already been deleted
  • save alpha values for GPX marker colors
  • added explanation to the "overwrite GPX file" dialog
  • inform user if not all files referenced by the session file are saved yet
  • allow user to save all files that are not included in the *.jos/*.joz but are only referenced in the session file
  • display * next to GPX layers that need to be saved (move isDirty() logic from OsmDataLayer to AbstractModifiableLayer)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.